No sound from internal speakers on Samsung Galaxy Book Pro 360 13"

I just downloaded Zorin OS Pro on my new Samsung Galaxy Book Pro 360 13". Everything is working fine except for the internal speakers and fingerprint scanner. The fingerprint scanner I can deal with later, and live without if needed.

I've been trying to troubleshoot this issue for the last 2 days with no luck.

I ran a lspci -v command and got this output for the audio

00:1f.3 Multimedia audio controller: Intel Corporation Device a0c8 (rev 20)
DeviceName: Onboard - Sound
Subsystem: Samsung Electronics Co Ltd Device c1a6
Flags: bus master, fast devsel, latency 32, IRQ 156
Memory at 601d190000 (64-bit, non-prefetchable) [size=16K]
Memory at 601d000000 (64-bit, non-prefetchable) [size=1M]
Capabilities: [50] Power Management version 3
Capabilities: [80] Vendor Specific Information: Len=14 <?>
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Kernel driver in use: sof-audio-pci-intel-tgl
Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

Hi and welcome to the forum.
I assume you have tried Zorin>Settings>Sound to investigate and test your speakers.

Next. Can you open terminal (i.e. ctrl+alt+t) then type alsamixer
Hit F6 and see what sound card/s are listed.
Hit F5 to show All sound channels then post a screenshot.

EDIT: See this.

Look at the last paragraph, which implies you need a later kernel or an OS with a later kernel 5.15 (e.g. PopOS.)

Thank you for the update!
When I check alsamixer the only device is sof-hda-dsp, or default.
Here are the screenshots

Also, is there any way to update the kernel while keeping Zorin OS Pro?

It's risky, but there's a PPA for a more up to date Kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline -y
sudo apt update && sudo apt upgrade
sudo apt install linux-generic-5.16

If it fails, you have to boot in previous kernel.

Thanks! I'll give it a try!

I was able to successfully update the kernel but I'm still not getting any sound

I just did a websearch using "ALC298 Ubuntu 20.04 no sound". Results not promising I'm afraid. But someone (post #18 in link below) has success with Fedora.

See this.

Which leads to this:

Still no luck. I am currently on the latest kernel 5.16.3 which was just released yesterday.

I did find that SOF 2.0 was just released with an emphasis on Intel Audio cards, but for the life of me I can't find any instructions on how to install it.

This is not for the feint hearted (me included), but from the SOF 2.0 link you provided above, there is a link to Github. From there you can get to this for the binaries:

Im sorry, I would not know what/how to install from there, or whether it would be any help to you if you did.

I'm having this same issue. It seems like some people were able to get the same speakers working on Manjaro. I followed the steps in this post but it seems like they're not working in Zorin.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.