No sound issue in Zorin OS 16.2

Hi everyone
I've installed Zorin OS to try it out because it's based on Ubuntu and I like the interface and other things in it but I have a problem. My sound card is recognized by Alsa and activated but I have no sound, I don't know why... I've followed some tuto to fix this kind of problem but nothing works...
My PC is a Samsung galaxy book pro 2 360 if you need to check the hardware.
In the tuto of sound troubleshooting of Ubuntu, they made me create a link to the Alsa config so I give it to you if it can help.

I ran sudo lshw -class multimedia and my sound card look to be claimed

I also make a post on stack exchange, if i get some answer in it maybe it could help you to find out the problem.
Other post link

I hope someone have an idea of how to fix it :grin:
If you need anything else to help me debug let me know!

You might try adding the SOF binaries if needed:

Please be sure to fully read the included instructions for installation.

If that does not work, you can try falling back the drivers to intel. You would need to edit your grub:

In your case, instead of adding nomodeset which is the example given in that guide, you would add:


So your line would look like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"

Remember to run

sudo update-grub

in terminal once you have saved your file changes.

1 Like

I've followed the tuto with the manual install because I didn't manage to run the

I don't really know if I've follow well the tuto because now my folders look like this and the output is on "fictive output" and the sof output doesn't display anymore.

Originaly, there were more files, maybe i should try to copy them inside and change the folder name? :thinking:

So I just did the step if it doesn't work and now I still don't have the sof output but I have a better thing I guess. However, the audio still doesn't work :sweat_smile:
Screenshot from 2023-04-28 11-52-17

Have you checked alsa in terminal and see if any channels are muted or turned down? If there is an M on any of the channels, it's muted.

I just checked and everything look okay, it's really weird. I've tried to change the output to headset and still the same thing.

Your alsamixer display screenshot does not show all the channels. See the stack of arrows down the right edge of screen.
Can you post a screenshot of full-width alsamixer with all channels showing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.