No sound on Asus T100 (there is speaker icon in the tray)

I'm running Zorin Edu Lite (64-bit) on Asus T100. Beside the webcam issue, it turns out there is no sound.

The sound/speaker icon in the system tray can be clicked and I can see some "Dummy Output" in the Output Devices tab. But that's just it. There is no "Sound" item in the Settings.

What can I do to diagnose and fix the issue? Thanks.

@hunggnuh85 Are you running Core or Lite?
Have a look at this thread and see if anything there helps you: Dell Precision 5750 - No sound ( Dummy Output )

Edit: see also: Headphones output no sound

Actually, if you hit the search icon, top right on the forum page and type "dummy output" you will find quite a few threads with that problem listed.

As I mentioned in 1st post, I'm running Education Lite 64-bit. Yes, I saw some of those threads, but don't know what I should try. A bit afraid of breaking things, make it worse etc... The strange thing is some guides mention about accessing Settings> Sound, but that's not available on my system.

Also tried alsamixer, it said no device available.

Sorry I saw "Education" and for some reason overlooked "Lite".
I am on Core, so cannot vouch that Settings>Sound should be same in Lite, though I though they were at least similar. Maybe @Aravisian or others on Lite can chip in.

Have you set your Software Updates to point to "Main Server" in prefrernce to a country server?

Then have you visited Software and checked for any additional drivers?

I have no idea what sound card is in your machine and their website does not seem willing to reveaal that information, even if we were to know which version of T100 you have.

Can you provide us with listing from this command:

I see you have provided more info on your machine here: Webcam not detected, dmesg | grep returns nothing - #4 by StarTreker

Ya, I gotta be honest, I'm not too happy about that tablet. Everything points to the fact that all hardware inside it, was software coded for Windows, with 0 compatibility for Linux.

I guess they never expected someone to put Linux on it. Just the fact it's running Linux is a miracle in itself! So props there I suppose.

1 Like

Well, the command returned nothing :neutral_face:

I booted to Windows and checked the sound component and there were 2 recognized devices:

  • Intel SST Audio Device (WDM): VEN_8086&DEV_0F28
  • Realtek I2S Audio Codec: VEN_10EC&DEV_5640

Changed the Software&Updates server to "Main Server" and clicked the "Additional Drivers" tab, it said there is no driver available.

Additional drivers tab is only for video drivers believe it or not. So you can't find audio stuff there.

Ah, I just did what zabadabadoo advised.

The issue is solved! I found and used the guide here:


Glad it is fixed and thankyou for posting the solution, which may help others reading here in the future.

1 Like

Well, I made it step-by-step but still no sound (and no camera anyway)... This solution doens't seems to work

Well, made it step-by-step... Don't work. Still no sound.

Start a new thread as your problem may be different, especially as you say you also have no camera.
Give details about your computer, sound card, edition of ZorinOS and a screenshot from running alsamixer in terminal.
Explain what sound and camera issues you are suffering. Does any sound work e.g. headphones?

1 Like