No sound on asus t100ta (sorry for my bad english)

Hello everyone. I bought an asus t100ta two months ago and the audio couldn't be enable. It had windows 10 and I'd tried ubuntu 22.04 and then the sound worked well but I couldn't install ubuntu. After all I installed zorin os but the sound don't work again. I read the others similar topic in the forum but it still don't work.

Websearch of "asus t100ta no sound ubuntu 20.04" gave this. I don't know if it will help you:


And also your camera dont work for sure. I run all the foruns, follow all the "solutions". A waste of time. Finally I found this cheap sound amplifier. It works

Before you installed Zorin, did you reboot or shutdown Windows? Big issue with warm boots and sound for Linux; somehow being held hostage by Win. Maybe boot the Win install medium, click around, then do a full shutdown to see if that helps. But, I've had nothing but issues with sound on all my newer Win laptops - and full shutdown was the fix.

Hope that helps!

That worked for me on the T100-HA

sudo apt update
sudo apt install --reinstall alsa-ucm-conf

echo "options snd-intel-dspcfg dsp_driver=2" | sudo tee -a /etc/modprobe.d/alsa-base.conf

followed by a reboot to take effect.


Thank you. Also work on T100TA. Finally

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.