No sound on Zorin OS 16.2 Xfce

my laptop has
CPU: Intel Atom x5-Z8300 (4) @ 1.840GHz
GPU: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx

inxi -SMA
System: Host: emmanuel-CherryTrail Kernel: 5.15.0-56-generic x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Zorin OS 16.2
Machine: Type: Laptop System: Insyde product: CherryTrail v: N/A serial: <superuser/root required>
Mobo: Insyde model: Type2 - Board Product Name v: Type2 - Board Version serial: <superuser/root required>
UEFI: INSYDE v: TURBOXx.WT102.OABNEEA01 date: 07/08/2016
Audio: Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit driver: N/A
Sound Server: ALSA v: k5.15.0-56-generic

Please open a terminal and enter

sudo nano /proc/asound/modules

and post back the results please.

0 snd_hdmi_lpe_audio
1 snd_soc_sst_byt_cht_es8316

If you don't use hdmi for external monitor, blacklist as per my tutorial here:

So, on my system , i should :
nano /etc/modprobe.d/sound.blacklist.conf
blacklist snd_hdmi_lpe_audio

Have I understood the suggestion of your tutorial well?????????

You will need to add sudo at the start:

sudo nano /etc/modprobe.d/sound.blacklist.conf

Then enter this after nano has opened

blacklist snd_hdmi_lpe_audio

Then save with Ctrl+ O (which is what ^O means. Any time you see ^ followed by a letter it means Ctrl+ letter. Ctrl+ X to exit nano.)

I blacklisted it, but still no sound...

You look like to have not created the blacklist.conf file as it won't be present. Take another look at the tutorial. Your screenshot implies you have tried to edit the proc/asound, but I could be wrong.

Open a terminal and enter:

sudo lshw -C audio

and post back the results please.

Screenshot_2022-12-15_20-26-45

I cannot post the result because it appears on the screen of the terminal
for a split second and then disappears !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Pretty sure that shouldn't happen. I will spin up my VM of Core and see if it happens to me. Will also try Lite as a VM too. But first, dinner.

OK, my bad, apologies! :flushed:

sudo lshw -C sound

this command worked

this site says:
Unclaimed means no driver.

Sadly that is correct. Remember these Notebooks weren't built for GNU/Linux. I would see if you can get hold of an old Dell or old Thinkpad to put Zorin on.

Can you get a cheap USB sound card for that PC?

thanks for your help, it doesn't matter very much, everything else works well on this old laptop, on Zorin OS. and it's not my every day computer