No Sound Output On a Dell Inspiron 5759

Hi all,
I have recently installed 16.2 Core on two different machines, one is an HP Elitepad G2 and the other a Dell Inspiron 5759 laptop, both installed fine except both appear to have the same audio problem where the drivers seem to have installed OK as everything is there but no sound output from the onboard speakers and with the HP Elitepa, no sound from the HDMI either, does anyone have any ideas how to fix this please

What is the terminal output for

sudo lshw -C multimedia


1 Like

You may want to share which video card is installed as well. Some gpu cards include sound cards (common on nvidia) and would make sense since hdmi shares no sound.

Hi Aravisian and 337harvey, thanks for the reply. This is what's listed for the Dell 5759.

This laptop has two graphics controllers, the Intel and the AMD. The sound card is showing as an Intel sunrise point but it actualy a Realtek ALC 3234.

1 Like

Or, the Intel may be the HDMI driver that is working and the Realtek wasn't detected?
Either way, their appears to be a sondcard installed as the controls are there and sound can be seen on the volume bar but no speaker output.

1 Like

Have you explored alsa and ensured all channels are not muted? Maybe changing the output to the loopback, as this resolved some sound card issues for others?

In alsamixer hit F6 and see what sound card/s are listed.
If there is a HDMI and another soundcard listed, select the other one.

Then hit F5 to show "All" sound channels.
Post a screenshot.

Gday @Mysteron ,Welcome to the community!

Try opening "PusleAudio Volume Control".
Goto the "configuration" TAB, in the top "Built-in Audio" this being your HDMI, set this to "Off".
In the "Builty-in Audio" under that,This is for internal/plugged-in speakers.
Set to: "Analogue Stereo Duplex"

Alternatively try these solutions.

Hope this may help

There are two sound cards detected but only one is selectable.

You did not follow this part of my previous post before doing your screenshots:

Then hit F5 to show "All" sound channels.
Post a screenshot.

Yes Zabadabado, its the first image but without the dialogue box.

Hi Ocka, just checked that. If I disable the HDMI no other options are available, in the drop down list there are only HDMI settings.

/With a grain of salt:
I think this is might probably be caused by the hybrid setup using Intel/AMD graphics controllers. Or, at the very least, you can troubleshoot the problem by switching the active graphics controller.

I use an Intel/NVIDIA hybrid machine, so I can't speak to your experience. However, I've found that when trying to use the Intel controller (set while within Windows), I get issues involving inability to boot and occasional flickering display - including the inability to use the HDMI port to pass video/audio to an external screen. I think this particular issue may have been caused because I installed Zorin with a "discrete" setup where I instructed my machine to only use the dedicated NVIDIA graphics card; essentially removing the "hybrid" capability. So, when I try to run my machine with the Intel controller, the OS doesn't know what to do in order to pass or display things properly. This is just a guess though.

As an NVIDIA user, I do have a tool available to me called prime-select and I can use the query option to determine which controller is currently being used. Though I still have issues while using the Intel controller, that tool also allows me to switch to the integrated Intel controller - which I never do.

That said, I did want to see if you can try to switch your graphics controller to rule out a similar problem being caused by your hybrid setup.

After doing a little searching, I found that users with an Intel/AMD setup can use something called vgaswitcheroo which is a kernel module to switch between the graphics controllers.

You can determine if the kernel module is available on your system by running: sudo ls /sys/kernel/debug/vgaswitcheroo/ or lsmod | grep vga_switcheroo. If the directory doesn't exist you may need to enable/load the kernel module with: sudo modprobe vgaswitcheroo. I tried this just to see what would happen, as it shouldn't be detrimental to an Intel/NVIDIA setup, but due to my running a non-standard kernel (I think), it can't be loaded because it's not part of my kernel.

If you do have the module available, you can try loading it with the modprobe command mentioned above. Once loaded, you can check the status of the graphics controllers and which is in-use with: cat /sys/kernel/debug/vgaswitcheroo/switch.

To switch to the other graphics controller, you can run: echo ON > /sys/kernel/debug/vgaswitcheroo/switch.

After switching the graphics controller, you may need to restart the X server or log out and log back in for the changes to take effect. I think you should be able to do this by hitting Alt+F2 and tapping r and Enter.

If you don't have any success narrowing down this audio problem, you can run: echo OFF > /sys/kernel/debug/vgaswitcheroo/switch to switch back to the original one. Again, restarting your X server for changes to apply.

Let us know what you think and if you do this, please share the results.

So after following the link to " How to fix sound in Ubuntu and Mint" from Ocka and following the first suggested procedure, we now have sound from the internal speakers :partying_face: :partying_face: Many thanks to all for your help and support. Now need to sort out the HP Elitepad 1000 G2 that has the same problem! I tried the same procedure but to no avail so will reload a fresh build of Zorin and try again!


Great to hear :+1:

Can i ask you to create "New Topic" Please. with the title referring to that laptop.

I have change this title & Moved to " General help".

Also Mark the post in here that Solved the issue.

Thank you.
Zorin Forum Community.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.