No sound via 3.5mm jack external speakers. Audio DOES work via USB headphones

Hello

I am very new (as of yesterday) to Zorin OS. I am trying it out via live "CD" (running from a USB drive). I am really enjoying it so far, but a fundamental issue that I am experiencing is that I have no audio coming out of my external speakers, which plug in to the back of my PC via a 3.5mm jack.

This works fine on my Windows 10 setup. It also works if I plug in my USB headphones.

I'm running Zorin OS 16 Core Edition. My motherboard is a Gigabyte GA-F2A68FHM-HD2.

I've tried installing some sound programs, but they give the same result.

I have checked for driver via Additional Drivers, but nothing comes up.

Any help would be massively appreciated. I really want to make the switch to Zorin, but without sound, it's putting a stop to it currently.

Thanks in advance!

Hi and welcome to the forum.
So you are running Z16 Core as "Try Zorin" mode from a live USB.

Which software did you use to burn the iso to the USB (e.g. unetbootin, rufus etc etc)?

As you have some sound output, in terminal (Ctrl+Alt+T to open) type: alsamixer

In alsamixer hit [F5] to show "All" sound channels.

If any channels show as "M" (muted), move your cursor across to it and hit M key on keyboard to unmute it.

Have a play with that, but if still have no sound then post a screenshot of your alsamixer and we will have a look.

Note: if you are running from Live USB without persistence, setting changes will not be retained over a reboot.

Hello and thank you very much for your reply. Cheers for the terminal shortcut too; I didn't know about that!

I'm still struggling with the sound unfortunately. I'm not running from a live cd. I'm fully installed to my drive.

This is what I'm seeing in AlsaMixer. Rear mic was muted, but un-muting it doesn't seem to have had an effect:

Quick update. The sound still isn't working, but in case you were going to ask me to do this, I just realised that some of the channels weren't turned up, so I've fixed that now:

I was indeed going to suggest you to do that.

Go to "Auto-Mute" channel and set that to Disabled.

You can also try "Loopback" set Enabled instead of Disabled.

In my experience sound problems are difficult to diagnose in a logical manner and often require trial and error experimentation. Sometimes that fails.

As you have installed ZorinOS, you can save any alsamixer setting changes using:

sudo alsactl store

I have been doing some websearches using "realtek alc887-vd no sound ubuntu 20.04" and see many reported issues, but no certain fixes.
I am wondering if it is a driver or linux kernel issue.

If I find anything more useful, I will post back here.

Thanks a lot for your help.

Unfortunately no amount of tinkering with AlsaMixer seems to work.

If you come across anything else, please feel free to reply.

If anyone else can help, please do!

Cheers!

** SOLUTION FOUND **

Hello

Just a quick update; my sound is now working! This isn't down to any tinkering; I bought an adaptor so my 3.5mm jack converts to USB. It was very cheap and worked instantly.

For anyone else struggling with sound, consider saving yourself some time by doing the same.

@zabadabadoo again, thank you so much for your help. Very much appreciate.

Take care.

1 Like

OK. Is the adapter from USB to 3.5mm jack?
I assume it is as you had USB headphones working already.

The other option, resorted to by others with persistent internal sound card issues, is to purchase an external USB soundcard. They usually come with 3.5mm jack/s.

The headphones that were already working are USB. The speakers are 3.5mm jack and I've purchased this adapter, which has worked:

1 Like