No sound [Zorin os 16.2] in Lenovo Y9000X 2019

I tried to install Zorin os a few times, and one of the installs had sound. At that time I installed Zorin os core. Later when I reinstalled Pro, there was no sound anymore.

Can you check in terminal:

alsamixer

Ensure nothing that you are running output on is Muted (MM)

You can also check by running

pavucontrol

Can you please relay the output of

sudo lshw -C multimedia

alsamixer


sudo lshw -C multimedia

According to this user:

The HengFeng patch resolved the issue. I am not certain on this, because by now, this pulseaudio patch should have made it into the Main Universe repo; but it is well worth trying:

https://launchpad.net/~kaihengfeng/+archive/ubuntu/fix-lp1869819
To run:

sudo add-apt-repository ppa:kaihengfeng/fix-lp1869819

sudo apt update && sudo apt install --reinstall pulseaudio

sudo add-apt-repository --remove ppa:kaihengfeng/fix-lp1869819

I reinstalled zorin and performed manual partitioning, as follows:

/boot
/boot/efi
/
swap

But there was still no sound, and then I reinstalled zorin again, but this time I did not choose manual partitioning, a miracle happened, and there was sound.
I have also tried manual partitioning many times before, but only divided into two partitions, /boot/efi and /, and then used automatic partitioning to reinstall, all without success. I guess, because I have two systems, windows and zorin, so when using /boot and /boot/efi at the same time, and then reinstalling, it will have an effect? I'm not sure what caused it. But it works perfectly fine now. Thank you very much for your help!!

1 Like

Right there:

That is where it is.

Windows OS DSDT table root bridge definition is reserved to a 32-bit space that manages the PCIe devices. Windows OS uses this root bridge definition to allocate PCIe devices.
Linux does not use this definition and may be used with the grub parameter pci=noCRS.
As Linux can make use of any and all available 64bit space and assign to PCIe at need, Windows is limited to its definition and would require a DSDT override.
It appears only a user Dual Booting could possibly run into this set of circumstances.
I do not fully understand all that I just said... as it is partly mashed with what I have read elsewhere. But you get the general idea...
Windows did not like the partitioning and was trying to apply its definitions when you applied your own /boot/efi partition for use in Linux, which was interferring with Zorin OS ability to access that partition and allocate space freely for PCIe devices.

Nice!! This information is very helpful to me! :smile:

1 Like