No System Sounds

Hello! I seem to have no system sounds, like when booting up, connecting usb, unplugging, error etc. Isn't it a thing in Linux? Or i have to use some utility to add them. And yes, "Enable Event Sounds" is ticked

Me neither. Thank god for that. It's the most annoying things when the computer turns into a robot from the 70's-80's sci-fi movies or worse Windows 95.

Will this help?

Startup application:
Startup Sound
command: /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

It was somehow disabled in my case.

Time to time my graphics card becomes default sound output. If you have more than one possible output, might want to check that out too.
[edit] I am using Zorin 16 Core (GNOME desktop).

Also before i do that, just saying, i found a post on linuxlite where someone said sounds are not there in xfce. Is it true?

Also, the command you sent is just for startup. What about other sounds?

Correct.
I always added a startup sound manually when I was using Mint XFCE.

I thought there was no system sound in Zorin Lite.

[edit]
I checked Zorin 15.3 Lite installed on another laptop.

All system sounds exist in:
/usr/share/sounds/

But I have no idea how to enable them in Zorin Lite.

Zorin OS does not come with system sounds. So if you want system sounds, you will need to download and install a sound theme. Swarfendor on here had made a thread at some point to links with some interesting ones as well as some hilarious ones.
Extract the sound theme and move the foo directory either to ~/.local/share/sounds or to /usr/share/sounds
In XFCE, open terminal and run
EDIT for Clarity: Replace "SoundThemeName" with the actual sound theme file name you installed.

xfconf-query -c xsettings -p /Net/SoundThemeName -s "foo"

You may need to add it to your profile: Open your ~.profile file and add the following lines to it:

GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
export GTK_MODULES`

Install the needed packages:

sudo apt-get install gnome-session-canberra sox

If neither of these packages are in the repository, you can look for them in pkgs.org under Ubuntu 18.04 or Ubuntu 20.04 - gnome-session-canberra sox

Ensure that event sounds are enabled in settings, then reboot to test.

1 Like

Is this it? System Sounds settings and Sound themes - Old Zorin Forum archive

1 Like