No Wi-Fi Adapter found (despite proposed solutions on Help Page)

I am really struggling to get my Wi-Fi working on my brand-new HP Elitebook 840 (7L7U3ET) with freshly installed Zorin OS Core 16.3.
Seems like my Laptop uses an Intel Wi-Fi 6 AX211 device, although "sudo lshw -c network" shows only "Intel Corporation" as Product.
Also tried to deactivate Secure Boot and Fast Boot in Windows...
Btw. more problems seem to exist (brightness keys on keyboard have no effect, HDMI external screen is not recognized/ shows no picture)
Any ideas for a solution?
Thank you very much!

These should be in separate threads as separate problems may have different solutions.
Keeping solutions confined to specific threads helps reduce thread length and makes them easier to find for other users troubleshooting.
I believe you probably have an Nvidia card and we can likely solve these two.
Can you please confirm if you have a Nvidia card and which model it is in your new thread?
The first thing I would try on the keyboard backlight is to add the grub parameter acpi_backlight=vendor

Yes, it will show as generic... it is frustrating.
For wifi6 AX211, the backport-iwlwifi-dkms should work for that card. If you can connect with Phone Hotspot or Ethernet, you can run

sudo apt update && sudo apt install dkms backport-iwlwifi-dkms

If unable to connect that computer, you can transfer the self-installer package from this location:

If you also need DKMS, its self-installer .deb package can be found here:

Thank you very much for your response!
I just ran your command and restarted my system. Unfortunately there still is no Wi-Fi being recognized. Is there anything else I could/ should try?

You are absolutely right of course! Actually I wasn't intending to ask for a solution of those problems but rather provide some more background to the original question. I am not familiar with such problems and therefore naively thought that they could have some common cause. Anyway my Laptop uses an Intel Iris XE card and no NVIDIA.

Can you please relay the terminal output of

ubuntu-drivers list-oem

If no output, please run:

sudo apt install linux-generic-hwe-20.04 linux-oem-20.04

Reboot and test...

Thanks for your patience!
My results:
Initially no output on first command.
Tried second command an rebooted.
Still no output for second run of "ubuntu-drivers list-oem".
Still no Wi-Fi recognized.

What is the terminal output of

sudo lshw -C network


*-network UNCLAIMED
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix cap_list
configuration: latency=0
resources: iomemory:600-5ff memory:603d1e4000-603d1e7fff
description: Ethernet interface
physical id: 2
bus info: usb@3:6
logical name: enxd2817a40e2bb
serial: d2:81:7a:40:e2:bb
capabilities: ethernet physical
configuration: broadcast=yes driver=ipheth driverversion=5.15.0-79-generic ip= link=yes multicast=yes

Let's try:

lspci | grep network

Done, no output from terminal.
Should I reboot?

Well, you had rebooted at post #4...

I am stumped. No output... Network unclaimed in spite of the installation of dkms backport-iwlwifi-dkms and the 5.15 kernel. It really shouldn't happen.
(This is in conjunction with your graphical drivers also balking).

If this is a fresh install - the initial installation may have had the "install third party drivers" option unchecked and it may be worth reinstalling Zorin OS with that Option Checked.

Well I am pretty sure I have checked the third party option during installation.
I also looked for the "Additional Drivers" tab in the Software & Updates App: not a single result.
Now I am wondering, whether the installation process would really access any other resources than the Software & Updates App?
Could there be a common cause for the multitude of problems I am encountering? To me, the lot of "sound is not playing, several keyboard keys have no effect, HDMI not working, Display brightness not changeable..." seems like a general problem with drivers?

And how likely is it that I would encounter the same problems with a lenovo Laptop having the same hardware (vs my HP laptop)?

Honestly... this pretty much only deals with Nvidia drivers these days.
It used to be that Jockey (additional drivers) would manage all third party drivers. But over time, more and more is included in the Kernel.

This is a very tough question.

I like honesty. Sometimes, being honest can be misleading.

The Wifi6 chipset
The Intel Iris Xe
...are both notorious on Linux for a *lack of support from Intel. I even just commented on this a day ago.

And Lenovo has increasingly become more and more dismissive of Linux with Lenovo notebook computers getting harder to support.

You might install on the Lenovo and have Zero Issues.
You can only test it and see...

1 Like

Oh I definitely appreciate your honesty!
And once again I am reminded of how important knowledge is...
During my hasty research I came to the conclusion that NVIDIA seems to be problematic with Linux but Intel should do just fine... Well that's obviously not the case!

But I am slightly in a hurry to find a working replacement for my old broken Notebook. So would it maybe be a saver bet to go with an AMD Ryzen 7-6800U processor and an AMD Radeon 680M graphics card? Or is their any notebook manufacturer more compatible with recent Linux? The WiFi 6 seems hard to avoid for the notebooks I am looking for...

And as far as my current HP notebook is concerned, a reinstall would be our last bet, right?

The problem is the hardware is newer than the firmware in this version of Zorin.

You can attempt to add the firmware manually, upgrade the kernel which will include newer firmware or attempt to use a newer Ubuntu based distro version (one that uses Ubuntu 22 or higher as the base). There is a guide to upgrade the kernel in the tutorials &guide section of the forum.

Zorin 17 will utilize Ubuntu 22 as the base, with the latest patches and firmware for that version. 17 won't be released for a few months yet though.

Wifi 6 is the latest and will only be supported in the latest kernels, with issues.

This happens when a distro is in the verge of a new release and new hardware is emerging.

Nvidia has a long history of conflict with Linux. But in the last couple of years, that has improved a great deal. I use a Nvidia card, myself.

In general, Intel works fine. There are a Lot of Intel products. But the Iris Xe chip in particular just is problematic. Which is annoying because it is a common chip still in wide use.

The vast majority are... I mean in reality, this forum gets a few help requests per day while averaging millions of users.

As near as I can tell - this is a Fresh Install, right? If that is the case, a reinstall is the first thing I would try, actually.
It is not normal for a user to have so many things go wrong as you described here. It really makes me wonder about the integrity of the .iso burn or the install.

Did that machine previously have Windows OS on it?

It has been around long enough that it is included in the backport iwlwifi, though.,

Still you make a good point. @Mike73 could try the later kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

1 Like

Indeed I wasn't aware, that my hardware is that new and would cause such conflicts. In any other scenario (no broken laptop and work up comming), I would have checked that more thoroughly.
But as far as I know the new Zorin 16.3 (which I stalled) is advertised as "powered by the same version of the Linux kernel as in Ubuntu 22.04 LTS" right? Or those that mean something different, I am not aware of?

I'll check that quickly...

This has been misrepresented by media and testers/ reviewers. Zorin 16, any point version, is based on Ubuntu 20. It is running the same kernel as when Ubuntu 22 came out, but that's not the same thing.

This IS a tricky one, isn't it?
I have been trying to wrap my head around how to succinctly word this for several days.

The kernel is a Mass of Drivers. And Zorin OS 16.3 uses the same initial kernel as Ubuntu 22.04. It makes sense to users to think - it should be about the same.

However... Zorin OS 16 is based on Ubuntu 20.04 when it was released. It is still using Libc6 version 2.33, I believe. Not Libc6 2.35 which is used on Ubuntu 22.04

And that one little dependency --- makes a big difference in so many things.

1 Like

This may be worth a try:

I have too many experiences of the AX211 wifi6 or other AX series working on Zorin OS to believe that this is an impossible situation.