No Wi-Fi P2P adapters found

Hello, I need help with this issue at Network Display tool. I have try everything but I could not find a solution. I need connect my Desktop PC to my laptop (Windows) across Miracast.

imagen

  1. Yes, I have a WIFI Adapter, specifically a TPLINK (TL-WN25N).
  2. I have the pro edition.
  3. This is the Network information ( sudo lshw -C network > wireless.txt)
    *-network
    description: Wireless interface
    physical id: 1
    bus info: usb@3:2
    logical name: wlx503eaa425641
    serial: 50:3e:aa:42:56:41
    capabilities: ethernet physical wireless
    configuration: broadcast=yes driver=r8188eu driverversion=5.11.0-46-generic ip=192.168.1.6 multicast=yes wireless=IEEE 802.11bgn

Please try: networking - Install TP-link TL-WN725N USB wifi driver on Ubuntu 20.04 - Ask Ubuntu

Hello @carmar, thanks a lot for reply. I did exactly that it say but its not worked, the issue continue.
imagen

There are linux drivers listed in the official website...but I am not sure if it will work withe kernel 5.11.

Did you run:

sudo modprobe -v 8188eu

In the OP, the noted configuration:

Ah...missed that totally. My bad.

Yes, I did it. I ran each command of the provider page and the forum but the issue continue.

image

Maybe, do you know how enable Wifi p2p operations en NetworkManager and wpa_supplicant?

Some computer manufacturers include a Physical Switch that disables the Wifi. While this can be handy... Many do not know that it is there and it can cause endless headaches as the user tries troubleshooting the software... Only to learn that switch was off.
Have you thoroughly checked if your computer has such a switch? It is best to check the manufacturer details, as the switch may not be obvious with a simple look at the computer.

1 Like

I learn something new today...Mine has a physical switch!

1 Like

Unfortunately it not has a switch for this

Have you tried a different USB port?
The drivers really seem to be included and I have done troubleshooting with that driver on this forum before...

Yes, each USB port, my motherboard is Asrock B550 Steel Legend with a lot of USB ports. Maybe its something that I have to enable in some place into the Zorin software? The Wifi adapter worked at Windows 10 and I could connect to my laptop with normally across Mediacast.

This is the driver your looking for

sudo apt update
sudo apt install git 
git clone https://github.com/lwfinger/rtl8188eu.git
cd rtl8188eu
make
sudo make install
sudo -i
echo “blacklist r8188eu”  >>  /etc/modprobe.d/blacklist.conf
modprobe -r r8188eu
exit

At each newer kernel version update, after the requested restart, please do:

cd rtl8188eu
make clean
git pull
make
sudo make install

Just to note, in previous posts, we see that the user installed this with DKMS, allowing Dynamic Kernel Module Support to modprobe the driver with each kernel update. It may be worthwhile to try installing it your method without DKMS, just to see if it works, though.

Hi, thanks for your help. I tried both methods but the issue continue. :dizzy_face: :dizzy_face: Im getting crazy. I am going to buy another wifi adapter tomorrow and I will tell you my result