No Wifi adapter found in Zorin 17

Good morning.

I just installed Zorin OS 17 Core in my laptop. I came from Windows, with all drivers and adapters working perfectly, but in this case, the WiFi adapter is not found. I'm connecting via ethernet in the meantime I found the solution.

I have been reading a lot of topics, but no one is working for me. I have secure boot disabled. I paste the following output of the sudo lshw -c network command. I can see it detected my WiFi adapter, but then, I can't connect to my home WiFi network, because the WiFi option doesn't appear.

~$ sudo lshw -c network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eno1
       version: 16
       serial: 00:68:eb:d9:23:42
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.5.0-28-generic firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 ioport:3000(size=256) memory:b4404000-b4404fff memory:b4400000-b4403fff
  *-network UNCLAIMED
       description: Network controller
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:b4200000-b4203fff
       description: Ethernet interface
       physical id: e
       bus info: usb@1:4
       logical name: enx86a5b9c3baa3
       serial: 86:a5:b9:c3:ba:a3
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=6.5.0-28-generic duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair

To finish, I attach one image of the network WiFi settings, and as you can see, the WiFi option doesn't appear.

Thank you in advance, and don't hesitate on contacting me if more information is needed.

Have you tried

sudo modprobe iwlwifi

Do you dual boot with Windows OS?

1 Like

Good morning.

Finally it worked by its own. Yesterday I went to bed without wifi option in settings and today it worked, even yesterday I reboot several times the PC.

But thank you so much for the information!! @Aravisian

1 Like