No wifi adapter found on Asus z690 wifi

No WiFI or Bluetooth adapter found issue on my 12th Gen alder lake pc. My mainboard is Asus TUF z690 wifi. Here is my system info Ubuntu Pastebin.

Kernel is 5.13.0-28-generic

I've tried full upgrade
iwlwifi driver install
Updated firmware

And no luck :frowning:

Your help is appreciated. Thanks

Hello @ashikrn.hq04 ,

would you mind specify the Zorin version you're running?

Have you tried to check here: Intel WiFi ?

In your pastebin, I do not see a wifi or bluetooth listed at all.
Can you please post the output of

sudo lshw -c network

Already mentioned that buddy. I've tried iwlwifi driver, no luck

Here you go Ubuntu Pastebin

I think nothing is here as well. My motherboard page says, it's 802.11ax wifi module. Though I'm not sure

Yes, Zorin 16 core. I can buy pro version as well if that works

Pro contains more goodies, but it does not unlock functionality. You do not have to buy Zorin OS for it to work. Choosign Zorin OS pro is a way to Support Development.

This is odd... Your output shows:

*-network UNCLAIMED       
       description: Network controller

But also shows your ethernet as well as wireless:

       description: Wireless interface
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl88XXau driverversion=5.13.0-28-generic ip= multicast=yes wireless=IEEE 802.11bgn

It shows the driver in use.
Your system output shows:

00:14.3 Network controller [0280]: Intel Corporation Device [8086:7af0] (rev 11)
	DeviceName: Onboard - Ethernet
	Subsystem: Intel Corporation Device [8086:0074]
	Kernel modules: iwlwifi

Did you modprobe your wireless driver?

@ashikrn.hq04 Can you do us a favour and edit your forum profile to indicate you have Core edition of ZorinOS. That will avoid such questions in the future. Thanks. zab.

1 Like

Hey, "ethernet" is there probably because I'm using USB dongle for wifi for now. And tried many solutions actually to figure out this issue. "modprobe" is probably part of that troubleshooting but I'm not much aware of "modprobe" I'm afraid.

"shows the driver in use" this motherboard has onboard wifi and that's appearing there. But without driver, it won't work.

Generally, Ethernet refers to hardline connection with a cable.
I noticed that yours says Ethernet Wifi - so that may be your dongle.
If you have a dongle for Wifi - this actually is the Simple Solution that many users opt for if they cannot find a driver for the built in chip.

Hi, I'm having the same issue on a s
Asus tuf gaming z690 d4, and I believe is the kernel. I tried different ones, 5.16 and 5.15.10, with that latter being that only one of the two that installed the drivers for both the wifi and Bluetooth, but it also remove the Nvidia driver for my card. Kernel 5.16 did not boot.


From what I can find searching, it seems 5.15 kernel is the one... But why would it remove Nvidia driver?
Did you also run

sudo ubuntu-drivers autoinstall


No, I did not. I'll try and report.

Installed kernel using synaptic package manager and everything is working, Bluetooth,wifi and Nvidia graphics card and driver.


Hey @Grim23 thanks. 5.15.10 solved my issue. I really appreciate your time. But now my PC isn't turning off :sweat_smile: After shutdown command, Mobo logo is there and stuck.

Anyway, I'll try to solve this. But it's pleasure that wifi and Bluetooth issue went away.

Thanks once again!

During shutdown hit esc or delete, it should show the shutdown process, it may give you a hint on where is your system hanging during shutdown.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.