No Wifi with Lenovo Yoga L13 Gen4 Intel i5 and ZorinOS 16.3


clean install, no WIFI is working.

Bluetooth is working, Airplane Mode is switched off.

LAN is working too via USB-C Dockingstation.
Latest OS updates are installed.
Secure Boot in UEFI is disabled

What can i do to get WIFI working. I am happy to receive help, i am a beginner and not a pro.

I am on Dual Boot with POP OS (wifi works there out of the box)

If i boot other Linux Live Distris via USB stick, Wifi works too.

It seems Zorin does not like my chipset

Thank you guys

if i boot in kernel 5.15.0-58-generic WIFI works, but trackpad doesnot work
If i boot in kernel 5.15.0-88-generic TRACKPAD works, but WIFI not.

Any suggestions to solve the issues.

Thanks a lot

Hi, What is the result of:

 inxi -Fxxxrz && rfkill list && iwconfig --sb-state

[Source: [SOLVED] Wifi Not Connecting, 'network unclaimed' on dual boot machine. - Linux Mint Forums]

Also in Pop! OS, when you run the

sudo lshw -C network

command, what comes back from that? Does it identify the driver needed?
The fact that your screenshot in the first post states it is unclaimed means the wifi card is recognised but it needs a driver.


Have you tried the -83 kernel?

sudo apt install linux-image-5.15.0-83-generic linux-headers-5.15.0-83-generic linux-modules-5.15.0-83-generic linux-modules-extra-5.15.0-83-generic


yes i tried also 5.15.0-83 Kernel, same problem - no Wifi but trackpad works.

Here are the other informations:

It shows you as having the iwlwifi driver. Have you modprobed it at any time?

I am sorry, but could you please explain what i should do. Dont know what modprobed does?


In terminal, run

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Here you are

Interesting about the remove option not working...
Well the modprobe did load iwlwifi on the second command. Can you reboot and test?

i did a reboot, but it does not work.

i also tried the live USB Stick Version 16.3 on a Dell latitute 5430 with the same result, no wifi.

Other Linux distro like MX, Mint, Ubuntu, Pop etc. are recognize the wifi adapter, so this must be a specific Zorin OS Problem with modern Intel Hardware.

Have you yet tried a kernel higher than 6?

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

You must reboot into the 6.3 kernel to test...

1 Like

If i start regular, my OS hangs with a black screen and this error message:

[ 0.611986] pci 0000:00:07.0: DPC RP PIO log size 0 is invalid

But, i found out a workaround:

switch off the Laptop
start the laptop
boot menu shows up
"Advanced options for Zorin" -> "Zorin, with Linux 6.3.13-060313-generic (recovery mode)
Recovery Menu shows up -> "RESUME NORMAL BOOT" -> confirm with OK to boot in normal mode
System starts with Wifi connected and active Trackpad

If i open terminal and enter

"uname -r"

i get the Kernel 6.3.13-060313-generic

But, if i restart the OS, i stuck again with the error above

[ 0.564161] pci 0000:00:07.0: DPC RP PIO log size 0 is invalid

EDIT: Sound does not work. If i press the F2 key for "rise volume" the onscreen display says "Dummy Output" but i cant hear anything.

F5+F6 for rise brightness does not work

This message in itself usually does not indicate something harmful. It is also not uncommon on Lenovo products.

Your issue appears to be that you are hanging at boot. There may be another cause.
You also are experiencing other hardware faults like no sound and non-working controls. So, right off the bat, I would suggest that the 6.3 kernel is not working out.

In PopOS, Wifi is working, what about sound and the brightness controls?

Thank you for your help. I came from Pop OS , everything worked fine there with my lenovo device.

So i will keep PopOS and will try ZorinOS later maybe with the relase 17.x

1 Like

I have marked your post as the solution for the time being...

One more question

PopOS runs with a Linux Kernel 6.5.6-76060506

Is it possible to install this in my Zorin OS envoriment to see, if Sound, Wifi and Trackpad works ?

Thanks for help

Yes, it is. Please see @AhavaLeaf 's suggested method here which I detailed in this link:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.