No WLAN adapter found

Hi, I’m new in Zorin. Installed OS 15.3 on Galaxy-Book. Got the message: No WLN adapter found. Network controller Qualcomm Atheros QCA6174 802.11ac.
Please give hints how proceed. Carolus47

1 Like

Could you please open a terminal (ctrl+alt+t)and paste in each of the following one at a time:

sudo apt-get install --reinstall git dkms build-essential linux-headers-generic

git clone https://github.com/tomaspinho/rtl8821ce

cd rtl8821ce

chmod +x dkms-install.sh

chmod +x dkms-remove.sh

sudo ./dkms-install.sh

1 Like

Hi, when I enter: git clone… etc, I get the reply: Username for https://github.com.

What do I have to enter? Carolus47

Ah… I am not sure on this. I would not have thought that using git would require the user to have a github account. But… who knows, since github was bought by Microsoft…
You can directly click the link in the instructions above and navigate to it in your browser. Select the code button, download zip.
extract it and move it to your home directory (Or you can leave it in Downloads and terminal ‘cd’ into it there) and then continue following the list above.
If you leave it in your downloads directory, you will need to Change Directory to that, instead

cd rtl8821ce

becomes

cd ~/Downloads/rtl8821ce

Thanks for the hint. Github for a newcomer is confusing. I opened github but no idea how to select the code button and download which zip.

I know what you mean, I am pretty new to Linux, myself.
I am fortunate that I enjoy learning things.
Here is the link again, so you do not need to keep scrolling up:

On the page, look here>

Click the green Code Button. You will see

Download Zip

Click that to download.

If it seems obvious in hindsight, don’t sweat it. When I first used it, I didn’t see it - if it was a snake, it would have bitten me.

Once you download it, it will land in your Downloads folder. Just open that folder and you will see it, there.
Double click it to open it with Archive Manager. On the top toolbar, it will offer to extract it- so click Extract.

I use Nemo File Manager, not Nautilus, - in my File Manager, I can right click anywhere in it and select “Open in Terminal.” I know Nautilus has that function, but it is not user friendly and I cannot remember how to find it. But you can just hit ctrl+alt+t on your keyboard to open a terminal.
In that terminal, paste in

cd ~/Downloads/rtl8821ce-master

That should open the terminal in that directory. Your terminal cursor should be preceded by this:

From that point, paste in each command, one at a time

chmod +x dkms-install.sh

chmod +x dkms-remove.sh

sudo ./dkms-install.sh

Most installs are NOT Tricky like this. But sometimes, when using an Independent developers patch for what the Realtek Developer SHOULD have done but didn’t… We need to jump through some hoops.

@Aravisian Thanks for the detailed explanations. The described steps worked perfectly, but the Wifi is still not visible. After a fresh boot, the module is not shown by sudo lsmod. I can load it via sudo modprobe 8821ce.
Some questions:
Do you own the same laptop?
How do you load the module (preferably automatically during boot)?
Does the network chip Atheros QCA6174 work with a Realtek 8821ce driver? (might be a dumb question)

The notebook I have is Acer Aspire V3. Something I would very much like to chuck through a window. Perhaps soon, I will get a good Tower. I have never liked notebooks…

Honestly - I have never once had this problem on any of my machines, three of which are different year models of Acer Aspire- one of them is a tower (that is the SG’s computer. My son has my old notebook.)
So all of my experience in the issue lies in trying to help others troubleshoot theirs and hearing their feedback -if they give any.

The Atheros QCA6174 should be compatible with Realtek 802.11ac driver.

Also, did you use -a?

sudo modprobe -a 8821ce

No -a, what is the difference?

Should I add the module to a file under /etc/modules-load.d/ or similar?

Yes. Head of the class- No need to ask me. :wink:

-a is “all” - to load all modules. It’s worth a shot, in case the user has several installed and one is the working one even if not the one that they think it is.

Edit: links:

The problem with Atheros QCA6174 is a kernel bug, https://bugzilla.kernel.org/show_bug.cgi?id=206567
The first reports are from 2017, and the tiny bug fix is from 2018. Unfortunately, the bug fix has not been accepted for the kernel, yet. So, you have to compile the kernel on your own.

2 Likes