Not a good day with Zorin Pro

Well, all of a sudden I noticed that my wifi icon is gone from the taskbar and when I try to open wifi from Settings and scan, it doesn't find any devices. Wow, this worked last week, what happened? Guess I can't attach my wifi speakers and they worked fine a few days ago.

And of course, the Software Center quit working again - can't wait for LITE. Hope it's more stable . . . guess I'll shut down for the day . . .

Things just don't disappear and quit working. There is one of two main explanations for this... either you removed something (apt autoremove possibly) or the drive has issues (corrupt sectors, failing). If you haven't performed any installations/ removals, then i would think it's a drive issue. How old is the drive? You may want to check it with fdisk in terminal or disks in gui.

2 Likes

Yep, you are correct. I removed FreeOffice app and in terminal it told me to run apt autoremove to uninstall things that were left behind. Does removing an office app mess with wifi? If it does, then I had no idea . . .

No, but autoremove can wreak havoc in your system...i imagine since you weren't connected to wifi at the time it removed the driver or some other dependency that was necessary. Always read what's being removed before hitting y.

3 Likes

I did read but I guess I missed something. Thanks for the help . . .

You can do a reinstall if necessary. Yes it will remove any applications, which will have to be downloaded. Save your home folder elsewhere, this has your os configuration files and most of the config files for your apps (unless they are snap or flatpak). I would use this as a last resort.

1 Like

I've got a full backup so yes I could put it all back easily. Might just wait for Pro Lite and install it instead. :grinning: :grinning: :grinning: :grinning:

Check /var/log/apt/term.log for what was removed (should be near the bottom) and you may get lucky by adding those packages again.

Just did a complete restore and wifi is working correctly again! Software Center is still out to lunch but I figured that. Thanks for the help on this.

5 Likes

There are many threads reporting that the Wifi Icon is vanishing all on its own from the Panel (taskbar).
I'm not sure this is solved, nor necessarily isolated...

1 Like

I see many people waiting for Zorin Pro XFCE.

2 Likes

I swear it's a gnome!

2 Likes

1 Like

That could be a true. Gnome fail. Near a taskbar shortcuts a clock time not working. Not all. Linux Sims things working great and another are problematic or confuse.