Not able to set Adobe reader as default for pdf

I have Zorin installed on both my desktop, an HP Prodesk 600 and my Dell Latitude 3160 laptop. I have adobereader 9.5.5 installed and working on both.

Here is where it gets interesting. I was able to set Adobe reader as default to open PDF files on my Dell laptop by right clicking on a PDF file to get to properties, then open with, then set as default. When I try the same procedure on the HP desktop, Adobe reader does not even show up as an option to pick as default.


evbrown, there are a lot of variables on how to resolve this depending on how the reader was installed.
If it was installed as a Snap file, you will find that the snap package is always set to read-only, disallowing user control. That may be why it is not showing up in the default list, as well.

There is a workaround if it is a Snap Package. THE BELOW IS FOR SNAP ONLY:
Bump your File Manager up to root privileges with

pkexec nautilus

For Zorin Core or

pkexec thunar

For Zorin lite and then navigate to
Edit the Exec line to:

Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/acrordrdc_acrordrdc.desktop /snap/bin/acrordrdc %f

Another option would be to remove adobe reader and install a non-Snap version.

If you are not using a Snap AdobeReader, please post your version and we can try another set of troubleshooting.

You have part of the solution I found. I installed Thunar. It allowed me to change the file association. I found the advice here:

Thanks for your help!

Thanks for sharing. :slight_smile: