Not able to uninstall microsoft teams preview edition

Hi I have installed microsoft teams preview application a long before from the software application but now I want to uninstall that. When I click on the show details of the ms teams get erron no details is available. Also tried uninstalling that teams using that (purge teams ) command but still it shows that the teams package was not there. Any one can help me with this.

Which version did you install? DEB, Snap or Flatpak?

If you just open the software store, search for Teams in your installed software, you should find a button to simply uninstall it.

Well didn't remember that its been a long. May be flatpak but not sure.

You can check if it is installed as flatpak or snap with

flatpak list

snap list

Ya I opened but that teams application is not available there. See the error what I got after clicking on show details.

Ya its flatpak
This I got
Microsoft… stable flathub system
What should Ido to uninstall

In that case, the uninstall was performed but the Desktop File was left behind.
The Desktop file causes the program to appear in App Menu.

Elevate to Root:

sudo -i

Launch file manager:


Tap the Up Arrow on the toolbar twice to get to root.
Then navigate to /usr/share/applications directory.
Search for the Teams Program .desktop file and delete it.
Refresh the desktop or log out / in or reboot to see the changes.

Command 'thunar' not found, but can be installed with:

This I got

Your Profile says that you are on Zorin OS Lite.
If you are not, please correct the Zorin Edition in your profile.
If you are using Core


instead of thunar.

  • (org.gnome.Nautilus:6134): WARNING **: 22:44:09.672: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory

** (org.gnome.Nautilus:6134): WARNING **: 22:44:09.672: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory
Nautilus-Share-Message: 22:44:09.798: Called "net usershare info" but it failed: Failed to execute child process “net” (No such file or directory)

This error I am getting. ANd when I run Nautilus command file prompt of with snap folder only. In that nothing is there.

That error can be ignored. It displays it because you are launching the file manager from / Root, but that data it cannot get is stored in /home.

Using nautilus elevated to Root, in the left pane choose "Other locations"
In the right pane, then select you Computer
Then navigate from root to /usr/share/applications

I am in the application folder what to do after that I didn't find any file with teams as name

Hmm, let's step back a moment - Is this how you installed it in the first place?

Through a .deb package?

May be I didn't remember exact but I think I have downloaded from software application using GUI

I ask because if installed from a self installing .deb package, it will not show up as installed in the Software Store.
You might Check your Home or Downloads Folders for an existing MS Teams .deb pacakge. If there is none, then download the .deb package from the link above.
Run it - then use the Uninstall Button from running the .deb package to run the removal for the software.

Well I didn't find any download link

Hmm... I had to look into this - I do not use Teams.

It seems MS has dropped the .deb (I do not know how recently) in favor of using PWA:

However, Microsoft has dropped the Teams apps for Linux in favor of the Progressive Web App (WPA) version of the service, which can also install on your computer for a more traditional experience.

They only offer it as a Snap which you can check with

snap list

Or a PWA web application.

I refered this and the software get uninstalled.

Thanks for your support :blush:

I never saw this post until now. Insteresting.

1 Like