Not dualbooting on msi motherboard

I am dual booting windows 11 and zorin os but when i am going to boot zorin it is stuck at the logo screen infinitely but it seems to work when i am going to advanced options and selecting recovery mode it seems to boot up i am usind a msi motherboard and i5 13500

Did you follow any recommended guide like this one?:

or this one which is more relevant:

Welcome to the Forum!

When you are using W11 you have Secure Boot and TPM enabled? If Yes that could be an Issue.

I have actually dualbooted Linux mint with win10 on my old laptop which worked fine

But now on my new desktop I have secure boot disabled and also tried disabling tpm but none the wiser

I have to go to recovery mode to boot in to zorin

There are two distinct things that can cause this.
Kernel issues: To resolve this you can try default testing on a different kernel

Graphics issues: To resolve this you can check which graphics card(s) you have and their drivers (which in some cases may necessitate changing the kernel).

Let's look at graphics, first. Are you using AMD or Nvidia or Intel?:

sudo lshw -C video

In some cases, graphics may load prior to the init of the display modules. Using nomodeset grub parameter prevents that from happening:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.