Notifications play out of wrong output

So I finished my install and set up pavucontrol but no matter what certain notifications only play out of my speakers, even when my Bluetooth headphones are the selected output device. I did find a solution, and that was to completely disable my speakers from pavucontrol. However I don't want to have to open it every time I need to use my headphones, just to fully disable my speakers. I was wondering if anyone knows why this happens and how I could fix it? It has done this since my first boot and no other distro has done that with my system so I am very confused.

update- after trying to remove and then add my bluetooth headphones again they do not work at all unless I disable the speakers in pavucontrol.

I guess it could be one of the following:

  • Conflicting Sound Servers: Ubuntu often uses both PulseAudio and ALSA for sound management. Your Bluetooth headphones might connect through one system, while notification sounds are routed through the other.
  • Application-Specific Routing: Some applications may have built-in settings that override the default sound output, forcing them to use speakers.
  • System-Level Sound Settings: The overall sound settings in your Zorin OS installation could be prioritizing speakers, even if Bluetooth is selected.

I personally recommend either using the command:

pactl set-default-sink bluez_sink.XX_XX_XX_XX_XX_XX.a2dp_sink

(Replace XX_XX_XX... with your Bluetooth device's MAC address)

Or go into the Pavucontrol settings and explore its advanced configuration options. You will likely be able to fix the issue from here.

Additionally, can you provide:

  • Which specific applications are sending notifications to your speakers?
  • Can you provide the model of your Bluetooth headphones (or speakers)?
  • What version of Zorin OS are you using?

All these details may be given so I could try to look into the problem more. Let me know if you try either solution.

Thank you!

I didn’t get a chance to try the command. I found out just switching to new Bluetooth headphones worked. My other ones were more comfortable, but it was a very cheap Chinese product. I tried out my Logitech headphones and bam everything worked. It always cut out every now and then in other distros too so I think those headphones may just be garbage I should use. Thank you for your help!

1 Like

That solution was... unexpected to say the least. But hey, your problem is solved! You're welcome!

I have marked your last post as "Solution". If this transpires to be incorrect, feel free to unclick that and continue the thread. Zab

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.