Numlock will not set to run on startup

I looked on Help, but no matter what I do the computer (HP ENVY 17.3) refuses to startup my keyboard Numlock even after saying it installed Numlockx. I am new to this can any one help me?

Can you try the selected answer here: https://askubuntu.com/questions/155679/how-to-enable-numlock-at-boot-time-for-login-screen ?

As for installation of numlockx, did you install using Synaptic? If not, then I recommend trying that. If using the terminal, can you verify your installed version using numlockx --version ?

Tried the Synaptic as you suggested, after signing in Numlockx was on, the issues is logging in. On my Linux Mint 20.1 - I can install Numlockx and it works great right from the login menu, however on “Zorin” it doesn’t and thats my issue making it start from log in screen so I can just use my numbers on the keypad with out always going through the hit Num lock key to enable the Num lock key pad from the very start after the computer starts up and ask for the pin. Hopefully I am explaining myself clearly new at this.

Your explanation is clear.

Two more recommendations, if you don’t mind trying them out:

  1. Can you try dconf-editor (alt+F2 and type dconf-editor in the box that appears)? If you don’t have it, use sudo apt install dconf-tools to get it. In the editor search “numlock” and ensure that both results are set to on.
  2. https://askubuntu.com/questions/1161166/how-to-enable-numlock-at-boot-time-for-login-screen-in-ubuntu-18-04

Carmar, finally it accepted the following:

1 Answer

ActiveOldestVotes

1

Do the following:

xhost +SI:localuser:gdm

sudo su gdm -s /bin/bash

Now, you need to use gsettings or dconf #or dconf-edit if you have it

Go to /org/gnome/settings-daemon/peripherals/keyboard/numlock-state and change it to on

or simply after the two lines do this

dconf write /org/gnome/settings-daemon/peripherals/keyboard/numlock-state "'on'"

or

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Now reboot

Thank you for helping me with this matter much appreciated.

2 Likes