NVIDIA drivers problem

Hello there !

I'm trying to install nvidia drivers but in settings still at "llvmpipe".
image

My secure boot is disabled, and i installed nvidia driver through Software Updater :
image

Can someone help me please ? :slight_smile:

@Aravisian advice, you should not go for the tested version as this causes issues. From your screenshot choose the 535 listed further down the list.

1 Like

@swarfendor437 thanks for your reply, unfortunately i changed to 535 listed further down the list, but still have llvmpipe in graphics

Did you reboot the machine after installing the drivers?

Yes i rebooted my machine

I assume you are on ZorinOS 17.1 Core.
Which Nvidia graphics card do you have?

1 Like

@zabadabadoo I have an RTX 4070

Have you tried the
550 (proprietary)?

Yes, same problem

Please launch terminal and run:
sudo apt remove --purge '^nvidia-.*'

Then

sudo apt install nvidia-driver-550

It will take some time. Once complete, run:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Watch for any errors. IF you see any, relay them in thread. Otherwise, Reboot the computer fully and test

nvidia-smi

@Aravisian thanks for your reply, I solved my problem by selecting the driver "NVIDIA driver metapackage from nvidia-driver-550 (proprietary)" :slight_smile: