NVIDIA GeForce RTX 3070 Laptop GPU not detected

I installed Zorin OS recently and my graphic card RTX 3070 Laptop is not detected and I have instead this weird name detected:
NVIDIA 01:00.0 NVIDIA Corporation Device 249d (Neofetch)

I installed the last Nvidia driver suggested by Zorin (535.113.01), tried a few ulterior driver version, even reinstalled the OS a few times, but my graphic card is just not detected, I tried several solution found in the web and nothing work

I'm a new linux user so I don't know how this really work and where to search to fix this issue, so I hope there is someone who can help me, thank !

See if the second post on this nVidia thread helps.

Notice that the OP had issues with Ubuntu 22.04 and didn't with 20.04, the latter is what Zorin is based on.

Also see if this nVidia guide helps:

Also, did you select the option at USB boot that says Try or Install Zorin OS (Modern NVIDIA Graphics) ?


You may also try using the 525 driver as there has been a few issues with the 535.

thank I will try it now, and if this don't work I will try this method

See if the second post on this nVidia thread helps.

Guys... none of this method solve my issue, I have always this weird name

Is your issue that the card is not Detected (and not being used) or that the name does not show up in the way that you expect?

In your O.P., it shows the Nvidia card as detected.

Some users seem confused, when coming from Windows, to see their hard drive listed as /dev/sda instead of as >C:

This does not meean that their drive is not detected. Can you please clarify this?
Tap alt+F2 and enter in nvidia-settings and see if your Nvidia configuration settings window pops up.

the name does not show up in the way that you expect?

no that's not the issue, in the first place I wanted to correctly install the drivers because my wacom display is directly connected to my graphic card, but my wacom screen just does not show up (before to make all this change, the wacom display was detected by gnome, but I was unable to use it)

see if your Nvidia configuration settings window pops up.

when I start it from the terminal

ERROR: A query to find an object was unsuccessful

ERROR: Unable to load info from any available system

(nvidia-settings:8175): GLib-GObject-CRITICAL **: 12:45:07.863: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:8175): WARNING **: 12:45:07.864: PRIME: Failed to execute child process “/usr/bin/prime-supported” (No such file or directory)
** Message: 12:45:07.864: PRIME: is it supported? no

and the graphic part
when I click on help

1 Like

I agree with you. Clearly the issue is not that the name is unexpected, but that the Nvidia Drivers are not loading properly.

Can you please try:
Remove all Nvidia drivers:

sudo apt remove --purge '^nvidia-.*'

Install Nvidia drivers:

sudo ubuntu-drivers install

Upgrade the kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Upgrade drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

I did all the command and update you said me to do, but literally nothing change, is even worse because my computer detect only one graphic card now
before :
now :

when I made the command sudo ubuntu-drivers install my screen just blank black and I waited like 1 hour before to force manual reboot

I wonder if you have Hybrid graphics setting in your BIOS / EFI Settings:

According to the above, the 510 driver apparently works. I recommend against the 535 proprietary driver. The 525 driver works well on my RTX 3060.

1 Like

Hey, sorry I was unable to used my laptopthis past week

Do you know how I can switch my Hybrid setting ? I search in my bios setting, but there was any setting to change the hybrid mode

You might take photos of your BIOS and relay them here... Other than that, I am not able to be familiar with your BIOS Settings enough to be very much help on finding or adjusting settings.
Hybrid Graphics are a BIOS setting. It cannot be disabled from with Zorin OS.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.