Nvidia on-demand gives blank screen

Hello,
I tried this solution, and the NVIDIA x server program worked again (it was also opening blank). Then I changed the options in the nvdia from performance mode to "on demand mode" and restarted zorin. But now when the system starts, show zorin symbol and then it stays in a black screen. Any suggestions how to fix it?

In /etc/default/grub, do you have nomodeset in your grub parameters after "quiet splash"? If you do, remove it and make it just "quiet splash".
If not, please add the xswat repo:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

And then upgrade your graphics drivers:

sudo apt update && sudo apt upgrade

If the above does not resolve the issue...
Then please remove the file:

sudo rm /etc/X11/xorg.conf

Remove Nvidia drivers, then reinstall:

sudo apt remove --purge '^nvidia-.*'

sudo ubuntu-drivers install && sudo apt install --reinstall nvidia-prime

Change to Nvidia:

sudo prime-select nvidia

Check your blacklist and remove any blacklist files:

sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf

sudo update-initramfs -u

Reboot and test

1 Like

Hi,
Sorry, just could find time to solve this now in the weekend. I had to purge and then reinstall NVIDIA driver (second suggestion) and it is all working fine now.

Thanks for the help! :grinning_face_with_smiling_eyes: