Nvidia only prime option is available

No option is available in X server settings. I have recommended driver installed.

1 Like

What happens if you run it from terminal with

sudo prime-select nvidia

?

If that does not work, there are two other possibilities:
The Nvidia driver is not initializing.
The Nvidia Driver needs to be changed for another version.

If Nvidia driver is not initializing, you may need to ensure that Secure Boot is disabled in UEFI.
It could be that you need to add

nvidia-drm.modeset=1

to your /etc/default/grub file (ask if you need a quick rundown on how to do that).
Or, it may be that Nvidia Driver needs to be replaced with a different version.

lakshya@lakshya-ROG-Strix-G531GT-G531GT:~$ sudo prime-select nvidia
[sudo] password for lakshya:          
Info: the nvidia profile is already set
lakshya@lakshya-ROG-Strix-G531GT-G531GT:~$ 

I got this output for `sudo prime-select nvidia

Looking at that makes me think that the Nvidia driver is not initializing.
Which driver do you have installed?

Nvidia driver 450. I have GTX 1650 4gb GPU

1 Like

I am guessing you have tried the 460?
Does opening Software & Updates > Additional Drivers tab show any updates to drivers?
Also (You may have said it before and I forgot) what kernel version are you using now?

uname -a

This may also relate to your backlight and brightness functions not working.

1 Like

I switched to 460 as suggested by someone online but it didn’t worked so I have to revert back
I am currently using 5.4.0-45-generic #49~18.04.2-Ubuntu
There is no update info for Additional driver

1 Like

This is odd… With Zorin updates, it should be at 5.4.0-66 now.
I think that upgrading your kernel to a higher version is the next logical step.

Can you run in terminal

sudo apt full-upgrade

Check if things are working. If not, proceed:
You can use an open source fork of ukuu simply called “Mainline”
I, personally, dislike Ukuu and have had it fail on me before (Resulting in a wipe and reload.) I will give the instructions here now… But stay alert…
You can install Mainline App with

sudo add-apt-repository ppa:cappelikan/ppa

sudo apt install mainline

Then run the app and choose your kernel that you want to install and it will give prompts to run the installer.

You can also use Synaptic Package manager to install and remove kernels- I recommend this one.
If you need to install Synaptic first:

sudo apt install synaptic

Open Synaptic (Then enter your password) and click Search on the Toolbar.
Enter into search “Linux-Image”
You want to select the Signed Image -Generic. Do Not Select OEM< Oracle, Azure, Low-latency, GKE KVM or AWS. So, you must scroll down a bit to Generic.
On Mine, I scrolled down to linux-image-5.8.0-44-generic. Right click it and mark for installation. A pop up window will offer Linux-Modules- Accept that (You would have needed to search for it and scroll for it anyway).
Next, back in Search, enter in “linux-headers.” Scroll down and select the one you want- on mine the highest signed generic is linux-headers-5.8.0-44-generic. Right click and select Mark for installation and accept the HWE it offers (HardWare Enablement).
On the toolbar, click “Apply.”
A pop up window will ask if you are sure and show Four Items. You can then click “apply” again to start the installation.

If the new kernel does not work, you can rollback to 5.4.0-45 from boot up - grub menu.

The last method of installation is a bit more manual- Download the .deb packages from here
https://kernel.ubuntu.com/~kernel-ppa/mainline/
and place all of the .deb files that were downloaded by themselves in one folder. Open that folder in terminal and install all at once with

sudo dpkg -i*

After install, you may need to run in temrinal

sudo update-initramfs -u

sudo update-grub

1 Like

I tried both method

while using this I am getting this output

lakshya@lakshya-ROG-Strix-G531GT-G531GT:~$ sudo apt full-upgrade
[sudo] password for lakshya:          
E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?

While trying adding repo everything working fine but again similar message

Reading package lists... Done 
E: The repository 'cdrom://Zorin-OS 15.3 Education 64bit bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I still tried to install mainline

but its aborting process

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  aptitude aptitude-common aria2 libc-ares2 libcwidget3v5
Suggested packages:
  aptitude-doc-en | aptitude-doc apt-xapian-index debtags tasksel
  libcwidget-dev
The following NEW packages will be installed:
  aptitude aptitude-common aria2 libc-ares2 libcwidget3v5 mainline
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,991 kB of archives.
After this operation, 16.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Abort.

I don’t know whats problem with my system! I don’t want to reinstall whole OS

1 Like

This means that you have more than one action trying to access dpkg or APT. For example, if you have synaptic open, then try to install something in terminal.
Or two terminals open, trying to install in each. The solution is to close out whatever else is open.

This can be fixed by removing the repository that is not properly configured.
What confuses me on this one is that it says
“cdrom://Zorin-OS 15.3”
You can open Software & Updates
then go to the Other Software tab
Uncheck the entry for cdrom:[Zorin-os 15.3…

2 Likes

estoy esperando zorin os 16 ultimate :innocent: :kissing_heart: