Nvidia PRIME was activated and destroyed performance. How can I deactivate/destroy/remove PRIME?

I have a dual GPU Desktop running Zorin OS with one monitor connected.
I was trying to get display out of my 1080's HDMI port as unplugging and plugging up my HDMI cable connected to my monitor would result into a black "no signal" screen. I was already getting display on my one monitor from my 1060. However, I was getting poor game performance out of my 1060 so I did some tinkering to try to get my 1080 to display. After many reboots, nothing was being done automatically even if the system booted with an HDMI cable connected to the 1080. After the system booted though, I could always plug into the 1060 and get display. In attempts to get my display working,


I used this command,
sudo prime-select nvidia
in ill hopes that I would be able to get display output out of my 1080.
Both cards are now in a type of hybrid mode and the performance dropped through the floor, even in the desktop environment. I now cant find a way to disable this prime mode and now, none of my games and AI stuff using anything CUDA (all my cuda tasks need 4GB+ of VRAM) will work.
If anybody knows how to disable or uninstall this feature, please let me know!
But hey, all my files are backed up on syncthing and another disk. I am not opposed to nuking my install.

What I have tried,
-sudo prime-select intel
I do not have integrated graphics, this resulted in a black screen but I could still use hotkeys to open a terminal and run prime-select nvidia and reboot to get display back.

-sudo apt-get remove --auto-remove nvidia-prime
this did nothing, to my eyes anyway.

The attached picture is representing the fact that my 1080 is being used as display out but, none of its ram is being used. I am only using 1 monitor, the 1060 should be drawing 5 to 3 W as there should be no load on is as it is not connected to a monitor.

This sounds a lot like a corrupted driver to me...
Can you try:

sudo apt remove --purge '^nvidia-.*' && sudo ubuntu-drivers install

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt full-upgrade

Launch Software & Updates and move to the Additional Software tab.
Ensure your correct Nvidia drivers are selected - if so - Reboot and test.


I'd also check your BIOS Settings. I've noticed on my ASUS mobo that Nvidia cards have to be in specific PCIe slots, with the others reserved for AMD. I tried to do this to enable VMs to access a second GT1030 card but never got it to work, so gave up on that idea.

Welp, that didn't work. Below is what happened.
Screenshot from 2022-12-13 00-06-47

I fixed it by installing an open source driver and using the update center to re-install a Nvidia driver.

But after some digging, I found out that xorg wants to draw the display on GPU 0 (thats my 1060). I guess there is a performance penalty when xorg is on a GPU that is not driving the display. I changed what GPU draws xorg to fix my problem fully. I ran this command,

lspci | grep VGA

To pull the values that are first returned to me in the terminal. For me, that was

When I changed the file below (I added a -jacob above the line you would un-comment) I placed

# BusID "PCI:9:0:0"

below my comment line, then rebooted my machine. I would have successfully put the 1060 to sleep (5w power draw, no vram use, no cuda use). Then, I could game on the 1080 and re-comment the file when I wanted to use my 1060 as a display (AND disconnecting the hdmi cable from the 1080 and plugging it in the 1060) after a reboot.

Below is the MODIFIED xorg.config found in /etc/X11

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 525.60.11

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"

   VendorName     "NVIDIA Corporation"

# uncomment below to use 1080 to draw desktop only (other programs draw on 1080) -jacob
#    BusID          "PCI:9:0:0"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

You are right, my 1060 is in the GPU 0 slot I guess.

So what do I do? my solution solves my case. I guess it had nothing to do with PRIME. Do I mark myself as a solution or Aravisian as one?

Wouldn't it be nice for Xorg to be used on the GPU plugged into a display after a reboot?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.