Nvidia Proprietary drivers not working Zorin 16 Core

Hello there, i have the same problem as @CaptainRyan, i have tried doing what you said but the proprietary drivers are still not functioning. Only the nouveau driver works.

What card do you have ?


I have an RTX 2060 Mobile

Can you try to install the nvidia driver manually. In the tutorial section there is a topic about it.


I recommend 470.74 or the 495.44 driver

1 Like

Hello, i followed the instructions, but when i got to the point where i had to blacklist the nouveau driver, after i rebooted my computer Zorin stopped booting up!

In my tutorial there is no where said you need to reboot the computer after you blacklisted the nouveau driver. You should reboot when you wrote in terminal systemctl set-default multi-user.target and then reboot. After that you would see a login prompt (step 9). If you follow the tutorial you will get your zorin back in no time.

Hello i'm sorry, i meant after doing those steps i rebooted but the system isn't booting up anymore. Do you have a solution for this?

@Michel , nomodeset?

He can try that to see if that will work for him.

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Its weird he blacklisted the noveau driver and rebooted and he does not get the login screen in tty. The only thing that comes up in my mind is to try a older kernel in the grub menu.

Hello, i had to boot in recovery mode then choose resume boot to get the command line or else it wouldn't boot then i just continued with the tutorial and it seems to be working now

1 Like

Glad to hear! Good job!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.