Nvidia settings not showing any of the graphics card settings

Please add the Xswat graphics updates repository:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then upgrade the drivers (and everything else)

sudo apt update && sudo apt full-upgrade

I managed to successfully do it!

Are the nvidia-settings now showing up?

I checked & it's STILL not showing properly.

What do I do? :thinking:

Do you have secure Boot enabled in BIOS Settings?
(It can interfere with the package).
Secure Boot is useless on Linux and is for Windows OS only. If youa re dual booting with Windows, you may want to have it enabled and will need to run through MOK on Zorin OS.
But if not dual booting, it should be disabled.

Then run:

sudo apt remove --purge nvidia

sudo ubuntu-drivers install

sudo apt update && sudo apt full-upgrade

It's currently on since I was running Windows 11, but I don't dual boot. Should I just turn it off?

Yes, I recommend disabling it.

Via the BIOS?

Yep, in BIOS settings.
In your other thread, I noted some instructions that require a reboot- so you may be able to get two birds with one restart...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.