Nvidia X-server only shows Prime Profiles

First of all, I'm new to linux, I installed zorin yesterday.

So, I was reading some articles about open vs privative graphic drivers, and i wanted to install bumblebee, so i went to the terminal and typed: sudo apt install bumblebee. When i did, nothing changed, there was no bumblebee app, there is no bumblebee command, the bumblebeed command does not work as well. I wanted to check Nvidia X-Server settings... Gone, there was no Nvidia X-Server settings, so i went and installed nvidia drivers... When i did so...

When i typenvidia-smi this is the output: "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running."

I also did some purge thing and installed the drivers again... I don't have much to lose in this installation, i could install zorin again, but it would be a hassle....

Any help is welcome.

You might ensure:

sudo apt remove --purge bumblebee

Then

sudo ubuntu-drivers install

You may open Software & Updates and check the Additional Drivers tab to see if Jockey is offering any other Nvidia Drivers or check which you are using.
You can see the Nvidia Proprietary drivers listed as well as the Open Source Nouveau drivers.

Thanks, that fully fixed my problem... Also, how do i force an app to use the nvidia gpu? or should i disable on-demand and go fully discrete gpu?

Ensure nvidia-prime is installed:

sudo apt install nvidia-prime

Tap alt+f2 and type in nvidia-settings
Or... In Start menu, type nvidia and then double click on `Nvidia X-server Settings

In the window that opens, click on Application Profiles in the left pane.
In the Right pane, click on the (+) Button to Add a rule.
A new window will popover.
Choose the Process Name.

1 Like

I didn't really understand that tutorial... I will search on youtube, thanks anyway.