Nvidia x server settings

Hi all,

Just now i tried to change resolution from my gtx 1070 card from 3840x2160p to 1920x1080p in nvidia x server settings, when i changed it i got a black screen and a mouse cursor. I could not do anything, i had to press the power off button for a long time to shut the system down. When i rebooted the machine it referted back to 2160p.

Question: Is it not possible to change resolution in linux ???

Have you tried in gnome settings?

Yeah no options there only 3840x2160

When i hit fractional scaling my desktop get huge icons, cant revert back and have to do a reboot with ctrl+alt+f1

What refresh rate?

60 if i am not wrong

You might try a different refresh rates.

I want to try to get 1080p to work, for some reason zorin wants me to keep 4k :joy:.

In windows i can lower it on desktop, linux has no option to that. Thats why i tried the nvidia settings.

In games i can select 1080p or any other resolution :thinking:

Have you tried any xrandr CLI commands?

To the OP, I know exactly what you are going through! Yes, believe it or not, I do!

I have also done the exact same thing, for the exact same reason, and I too failed. The OS refuses to set a screen resolution that is bellow your native resolution for the desktop. It is indeed possible that this is a bug that has had no resolution yet.

I just gave up trying to get this to work, and decided to just be grateful that the OS functions at my native 4K resolution of my TV at all. Which also happens to be, 60-hertz.

My recommendation is to set your game resolution, in game, to 1080P. And for the few games that won't let you do that, edit their configuration files to force the game to launch in 1080P.

And if the game is just really super de duper weird, and it doesn't let you set game resolution in game, or in a config file, then your other option is to add a launch command for the game in Steam, to force 1080P.

  1. Right-click on the game title under the Library in Steam and select Properties.
  2. Under the General tab click the Set launch options... button.
  3. Write: -screen-width 1920 -screen-height 1080.