O ZorinOS Lite não reconhece meu teclado pós instalação

Bom, quando fui instalar o ZorinOS Lite em meu MacBook White 2008, usei o Live Boot pra dar uma conferida no sistema e tudo funcionou perfeitamente, porém, quando fiz a instalação em meu Disco Rígido o teclado mesmo configurado como “English (US) / Intl” que é o Layout dele, reconhece de maneira estranha, acompanha um vídeo de como está funcionando, desde já peço ajuda para resolver esse problema.

Obs: Isso não aconteceu no Ubuntu e nem no Kali Linux.

IMG_0208

Como vocês podem observar no gif, quando eu aperto a letra “J” ele reconhece como o número “1” é assim acontece com as outras teclas, parecendo que o sistema reconhece somente teclado numérico.

1 Like

English translation:

Well, when I went to install ZorinOS Lite on my MacBook White 2008, I used Live Boot to check the system and everything worked perfectly, however, when I installed it on my Hard Disk the keyboard was configured as “English (US) / Intl” which is his Layout, recognizes it in a strange way, comes with a video of how it is working, I ask for help to solve this problem.

Note: This did not happen on Ubuntu or Kali Linux.

As you can see in the gif, when I press the letter “J” it recognizes the number “1” as it does with the other keys, it seems that the system only recognizes the numeric keypad.

@LongestyCandy Yes looks like the integral numeric keypad is active instead the normal alphanumeric keys as J=1, K=2, L=3 etc.
Is there a key on the MacBook to switch the numeric pad to alphanumeric?

@LongestyCandy Sim, parece que o teclado numérico integral está ativo em vez das teclas alfanuméricas normais como J=1, K=2, L=3 etc.
Existe uma tecla no MacBook para mudar o teclado numérico para alfanumérico?

1 Like

Olá @zabadabadoo, obrigado por me responder, mas agora respondendo a sua pergunta, não, não há nenhuma chave física no MacBook que faça essa troca entre o teclado alfanumérico e o teclado convencional.

1 Like

Translation:
*Hello @zabadabadoo, thanks for answering me, but now answering your question, no, there is no physical key on macbook that makes this switch between the alphanumeric keyboard and the conventional keyboard.

[Num Lock] key?
or try "US English" not "US English Intl" keyboard setting.

1 Like

Não há a tecla Num Lock no teclado do MacBook, e o English (US) ainda assim não funcionou, já que ele é basicamente a mesma coisa do “Intl” só que o “Intl” é internacional ou seja posso utilizar da acentuação brasileira.

1 Like

Sorry. I don't have a MacBook, so I can't help you more except do some web searches, or plug in an external keyboard to see if that is also affected.

From my websearch using "Mac keyboard typing numbers instead of letters", maybe one of these will help. You may need to search more yourself.

This mentions [F6] acts as Num Lock on some Mac's

Also:
https://discussions.apple.com/thread/3065163

2 Likes

Isto é o que posso sugerir :point_down:

:point_right: Definições > Região e Língua > clique no botão com o olho no seu teclado actualmente activo > prima várias teclas para ver o que a ferramenta lhe mostra

:point_right: verificar se tem pelo menos uma das opções disponíveis instaladas na secção de Fontes de Entrada em Extensões no Centro de Software

:point_right: Configurações > Região e Idioma > clique no botão com a engrenagem > Utilize a mesma fonte para todas as janelas deve estar activa, para que não esteja a utilizar métodos de entrada diferentes entre janelas

:point_right: Definições > Região e Idioma > Gerir Idiomas Instalados > experimente as diferentes opções disponíveis em Sistema de Entrada de Teclado:


Here's what I can suggest :point_down:

:point_right: Settings > Region and Language > click the button with the eye on the currently active keyboard > press several keys to see what the tool shows

:point_right: verify that at least one of the options available in the Input Sources section under Extensions in the Software Center is installed

:point_right: Settings > Region and Language > click the button with the gear > Use the same font for all windows must be on so that different input methods are not used between windows

:point_right: Settings > Region and Language > Manage Installed Languages > try the different options available in Keyboard Input System:

Se não estou enganado, vc tem que escolher a opção "English International with dead keys" para funcionar no Zorin.

1 Like