OBS Studio - No Screen Capture on Zorin OS 16.2 Wayland

Hello there!

I have just installed OBS Studio 28.1.2 from Flatpak but when I want to record my screen, there is no screen capture or window capture option.

Has anyone have this problem before? Is there any packages that I'm missing?

Screenshot from 2022-12-09 19-44-09

It might be that the flatpak havn't permission to do that. Try the .deb package and see if it solve the problem.

EDIT: I checked the flatpak version. Did you enable all the plugins that comes with it?

1 Like

Oh my! I didn't notice any of the plugins :smile:
However, after installing all of them, there is still no option for screen capture sadly.

I didn't want to use the deb version is because it is really old. :confused:

question, what do you need OBS for? Broadcasting?

Just for screen recording for work (Guides, SOP) :slight_smile:

I have tried Kooha which a simple screen recorder but it always throws an error and doesn't work either.

Try GPU Screen Recorder. It's available as flatpak and I use it make my videos .

Shameless promotin :smiley:

EDIT: Link to GPU Screen Recorder: GPU Screen Recorder | Flathub

1 Like

5 posts were split to a new topic: Tangent of OBS Studio -No screen capture

Sorry for the late reply, I accidently broke my desktop while trying to get it working. :face_with_spiral_eyes:

I have found that Wayland was the problem, because when I switch to X11 desktop, everything worked.

Looks like the solution for now is to use X11 when trying to record my desktop screen. :confused:

P.S Love that animated dragon background btw :star_struck:

For desktop recording of Tutorial videos I made for work during lockdown I used VokoScreen recorder then used KDEnlive to upload to Vimeo. Am going to look for something that is not Pulse Audio dependent like VokoScreen is.
Just found it, Simple Screen Recorder and works on older kit too.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.