Oh man Zorin OS is slooow and unresponsive after boot

I dont have the volume bar for some reason as i type here. Which was there before i restarted the pc

Anyways this is my second time talking about this same thing. I have this issue only after boot . Like all apps even default zorin apps are slow idk why. Plus firefox is now snap so...

Im going to have to restart my laptop again cause i still dont have my monitor as a sound output device option idk why.
image

No, not on Zorin. They use the Flatpak-Version as preinstalled Software not the Snap-Version.

For the Audio Issue: Did You tried it with pavucontol? To get it open the Terminal and type sudo apt install pavucontrol

1 Like

Know which sound card you're using? Might just be a driver issue.

Two things I can think of off the top of my head might be Secure Boot or a dual-boot setup - Secure Boot could be blocking driver / HW use, and dual-boot could be playing with busses on a reboot. Had dual-boot reboot issues with my Zorin 16.3 Core setup and Win11 - if I didn't shutdown before booting Zorin, no sound ..

Also maybe check alsamixer as well - you can see all input / output devices and their levels. Definitely give pavucontrol a shot too.

1 Like

Please open a terminal and enter:

sudo lshw -C sound

and post back the results please.

1 Like

Zorin OS is not affected by this, they use the official Firefox Flatpak.

Regarding missing audio, it seems the audio server is (for some reason) not running, or not running correctly.
This isn't the dreaded "Dummy Device" issue, because then it'd say that, and not null.

Please try running the following to see if it fixes the issue.

systemctl enable pulseaudio --now --user

If not, or if it says that it's already enabled or running, try the following to restart it:

systemctl restart pulseaudio --user

If neither of those fix it, please provide an inxi report for your audio devices like this:

# install inxi if it isn't already. This will ask for your password.
sudo apt install inxi -y
# Get Audio information from Inxi.
inxi -A 
# OR, Alternatively:
inxi --audio
2 Likes

Perfect doing this got my audio controls back , but any idea about why the whole laptop is slow after boot. Like even the basic apps like settings


also was like this when i opened my laptop ( was on sleep before )
is it normal ?!

welp audio controls are there but only system default sounds are audible , youtube video sounds are not


image

{ Edit }
After a lot of trial and error , pulseaudio is finally working . Audio is back !

1 Like

According to linux-hardware.org it should not work at all!

I found this askubuntu thread which may help or hinder.

1 Like

To be honest I don't know. I see that you have a 8-Core CPU so you Laptop shouldn't be too old. Maybe it could be a Kernel-Thing ... I mean, that Your Hardware is not supported enough. Did you tried Zorin Lite? Or another Distro with a Gnome Desktop Environment?

1 Like

No, not yet , tho an update
I cleared firefox's cache and cookies about 2gb's worth
cleaned my laptop a little and things have been better

also i have preload installed but i doubt if it works as intended
but overall things have been better after some cleaning .

1 Like

It works like this in the real World and so in the digital World, haha!

1 Like

Might want to check your Journal/Logs for errors:

In terminal do a

journalctl -p 3 -xb

2 Likes

oh hello, that is all kinds of f*kn weird

2 Likes

What is the exact make and model of your laptop?

I did find that ^^ May want to check alsamixer to see if auto-mute is enabled for some reason. If you find anything that doesn't seem right and change it - issue sudo alsactl store to save the config.

If you do want to check out another distro though, I'd say check out something with a MATE environment. Little more XP-ish but, pretty good with HW support; saved me with a newer Gateway laptop and an older '09 MacBook!

Yo Thanks ! But got my audio working . Had to do some tweaking in pulseaudio and stuff but finally got it working .
Now have to check how to go about bluetooth devices since my wife and bluetooth frequency interfere with each other

image

1 Like

You may need to check that they are not on the same channel.

2 Likes

Ok this is making me mad now !

Firefox crashed 4 times , and showed this message about 7-10 times before i could write this
image

This happens only on boot so i doubt if its an hardware issue .

This is what stacer shows on boot


Pretty sure thats not normal btw this is only after running discord and stacer
Also this is how it looks normally

Any idea , should i switch to Thorium / any firefox lite version or something wrong with my laptop itself

You could try starting firefox from the terminal, keep your eye on the terminal while you use firefox, if it errors it will show you in the terminal...

When your Systemload is so high Firefox can't run good I think. The Main Question seems to be: Why is the Load so much? Do you have any Background Programs or Services on Startup?

1 Like

ugh

image



1 Like