Oh no! Something has gone wrong. A problem has occured and the system can't recover

After sudo apt install --reinstall zorin-os-desktop gnome gnome-shell error like this

From the Recovery Menu:

Please arrow key to root - drop to prompt and run:

sudo dpkg-reconfigure gdm3

Error like this
gdm.service is not active, cannot reload. invoke-rc.d: initscript gdm3, action “reload” failed.

sudo systemctl start gdm3.service

sudo dpkg-reconfigure gdm3

Still error like this again

Those errors all say that you have no internet connection.

Are you able to reach the desktop?

Can not able to reach desktop

In the Recovery Menu, there is an option to Enable Networking.
Are you able to enable networking, then in Root - drop to prompt, able to run sudo apt update without errors?

I already in conncetion and i can run apt update but i try sudo dpkg --configure -a the result is nothing

Already - before those errors you showed that showed no net connection?

If you are connected to net, please run

sudo apt install --reinstall gdm3

It's success, what's next bro ?

Try booting up and see if you can reach the Desktop...

Still not able to desktop

Back to the Recovery Menu

Enable Networking

Root drop to prompt


sudo apt --fix-missing

sudo apt update && sudo apt upgrade

sudo dpkg --configure -a

sudo apt clean && sudo apt autoremove

Back out to the recovery menu, then back to the grub menu - proceed to test boot to desktop.

sudo dpkg --configure -a

Not working isn't it ?

The command won't necessarily print output. It just performs its task.
Go ahead and test booting up...

Still not able again

How do you feel about reinstalling Zorin OS?

Have you backed up personal data?

I not back up the data

Using a LiveUSB of Zorin OS, you can try to access your hard drive and transfer personal data to a safe location.