Old topic, still no answer I can find. AX201 very slow wifi

Hello all,

I've just reinstalled my system with Zorin 16.3. Nice look/feel. Good job guys.

I'm running on Lenovo T14 Gen 2 Intel which has AX201. Unfortunately the wifi is too slow which has been reported many many times on the web. I've spent the usual minimum 8 hours trying all the tricks on the web, powersaving modes, various config file changes etc. As much as I like to tinker, I can't let this be limiting during the working week.

As an example, my Pixel 5 Phone, partners old 2012 Macbook Air, my Pixelbook are showing approx 25-30mb download speeds using fast.com. On the above install I'm getting 15mb. We're 1m from the router no interference. The same above laptop in Windows 11, same 25-30mb speeds. This is a driver issue but not on some usb live versions! So frustrating.

I've just tried a USB install of Ubuntu 22.04, worse. Elementary OS 25mb and at the time of writing I'm downloading latest versions of Elementary, POP and Mint.

With Zorin it's Kernal - 5.15.0-87-generic

With Elementary (older 6 version, currently downloading 7) is I think - 5.15.0-85-generic.

What am I missing here all?

As much as I like the look of Zorin, I'll go with the one which has less limiting issues.

Cheers all.

I would recommend getting an inexpensive wifi dongle from your preferred retailer and using it instead of the AX201 which seems problematic across distros.

Replacing the troublesome hardware with well supported working hardware may be all the solution you need.

1 Like

What type of router make/model do you have? There may be some increase after changing some settings..

Which spectrum are you using - 2.4GHz or 5GHz? My new-ish little toss-around netbook deal has only 2.4GHz, I can really max out around 30-50Mbps, on a good day.. There might be some settings for 'legacy' support that may or may not be enabled - for very few of my own devices, this was slowing them down opposed to what they were getting before. My PSP has very outdated WiFi and only connects to my router when I mess with a lot of settings to make it work (it has an 802.11b chip). Encryption may be a factor as well, AES or TKIP - TKIP is typically has a faster link speed.

Also, check any 'width' settings in wireless - usually with 2.4GHz in the 20-40MHz range - and with 5GHz 20-160MHz. If the device is only using a certain width, that might also affect speed, which if at a lower width - slower speed.

(edit)
Forgot - fast.com is a good one, it shows a loaded speed test vs just transfer speed. I would suggest installing the speedtest-cli package - run with speedtest - no GUI, no web browser - just pure speed testing :grin:

Cheers, would be a shame to use a port up for that job taking more battery as well. Just can't put my finger on why it works on Elementary which is also Ubuntu based, but runs like a dog on Zorin.

It's a low quality Cosmote box here in Greece, portable with battery which is useful but defo low quality. However as above, same box on Windows/Elementary, much faster. Only 2.4ghz option and I've tried with no security as a test also, but no better. Why this problem exists I can't see why as the AX201 is not a niche product. Never mind, tihnk it is goin to be a Sunday reinstall.

1 Like

It may be a firmware issue:

I have not scrolled up to check the things you have tried...

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.