Only background no terminal no app (zorin os lite)

I just started my laptop !! Then I stacked with only my desktop background without any icons no panel no menu !! I can’t do any thing ((only +/- volume… Also my Pc detected my wifi automatically)) I tried to open Terminal with the Shortcut (ctrl+alt+t)I got the error says
*" failed to lunch shortcut "
failed excute child process exo open ( no such file or directory) *****
ANY HELP PLEASE !! I’M STACK

Try: sudo apt --reinstall install lightdm

This sounds like XFdesktop and exo have both failed to initialize.

Is this a fresh installation?

Did you remove any progrmas, including one called “Web Browser?” Some applications, such as “Web Browser” take the Desktop environment with it.

To restore, you must start in Recovery Mode. Boot the computer and immediately hold down the Left Shift Key. Sometimes, stabbing the key repeatedly works better.
Once you get to the Boot menu- select “Recovery Mode.”
At the Recovery Mode Menu, select “Enable Networking.” Once networking is enabled, it will automatically return you to the Recovery Mode Menu.
From there, now select “Drop to Prompt.”
In the prompt, hit enter to start, then enter in the commands

sudo apt update

sudo apt-get install zorin-os-lite-desktop

IF… For whatever reason, “sudo apt-get install zorin-os-lite-desktop” does not work, you can use:

sudo apt-get install xfce

which will reinstall the XFCE D.E. and get you up and running.

1 Like

How can I try this ??? No terminal I said

I’m glad you’re here… Actually you’re right I installed something before i shutdown last time , if i remember something like Vim …
I tried to do all what You said,
Look what they say that there’s some broken packages

And when I rebooted , keep the same problem.

Ah, I see. Yes, you may have gotten bitten by the “sudo apt-get autoremove”

Do not worry, all is not lost.
Go back through the recovery menu as above, after enabling the Networking and drop to prompt
Enter in

sudo apt-get install -y zorin-os-lite-core

sudo apt install -y xserver-xorg-core

This one is IMPORTANT

sudo apt install xserver-xorg-input-all

Then,

sudo apt-get install -y zorin-os-lite-desktop

You MAY get a notice on trying the next line that something is already installed- that means only that your previous installation installed the item you are trying to install after- I am only trying to be thorough.

1 Like

Everytime I enter a command , always there’s an error of broken packages.
This is the last command error

this is also another error I think for the first command

I am sorry, I seem to be a little slow this morning. I am noticing that in your screenshots, your sudo apt update is Failing to resolve the ppas for Zorin and Ubuntu.
Are you enabling Networking before dropping to prompt?
It looks like there is no net connection.

1 Like

I think I DID, I repeated everything again , when I enable network they said done and return to recovery menu …
I tried the sudo apt update . That’s what i get

That screenshot shows no net connection. Hmmm… Are you normally connected through WiFi?
If so, you may need to connect Directly through LAN cable. I hope you can connect wired for a moment…

1 Like

Excuse me for taking too much of your time.
I connect now Via cable…
I entered all the commands
It’s take too much time of setting up progressing. (Sometimes I see there’s unpacking lines…)
Then i rebooted !
Unfortunately No news !

Accually , there’s a good new thing .
I can launch Terminal using the shortcut

You are launching terminal from the Graphical Interface?
Ok, from that, this means xorg is running

From there, you can try installing the zorin desktop core and zorin desktop common

sudo apt-get install zorin-os-lite-core

as above commands we tried earlier, then reboot…

1 Like

Yes I’m exactly in the Graphical interface.
I tried this command
They said already in the newest version 0 upgrade 0newly instal 0 …

Well… interesting.
And still not seeing your panel?
What happens if you hit alt+F2 and enter in

xfce4-panel

alt+F2 and enter in

xfwm4 --replace

1 Like

No panel before nothing only background.
But
For xfce4-panel
I entered it then the panel shows
For the second xfwm4 --replace
My desktop background change … mixture of my background +black but the panel still there .

Ok… in terminal on that machine, run

sudo apt update

Check that you do not see the “FAILED” messages like you saw before.
Then run

sudo apt install full-upgrade

1 Like

A

I am sorry- my brain…

sudo apt full-upgrade

I have been typing “sudo apt install” a lot in another thread. My fingers went on autopilot.

1 Like