Onscreen keyboard doen't work

I have installed Zorin 16.3 Pro. Unfortunately, the on-screen keyboard does not work. When I click in a text field, the keyboard appears, but unfortunately it does not respond to any input. I have also installed Onboard but when I click into a text field, the Gnome on-screen keyboard opens. I disabled the onscreen keyboard in the accessibility settings after I installed Onboard.
What unfortunately also does not work via touch is launching applications from the bar.
The computer is a HP Pavilion x360 Convertible 14.
What other information is needed to help me?

From your post, it sounds as though the built in on-screen keyboard is launching. However, it is not responding to Touch Screen input. Have you tested it with Mouse Input?
The issue may be a touch issue, not an on-screen keyboard issue.

from what u have said, it sounds like u are having an issue with ur touch-pad. try clicking the on-screen keyboard keys using left key or right key of ur touch-pad or if u have an external mouse u can use that.

Thank you very much for the answer. I think it is a combination of a touch problem and an on-screen keyboard problem. With the mouse the input works. That points to a touch problem. On the other hand, yes the onboard keyboard works with touch. This then points to a problem with the Gnome on-screen keyboard. I would use Onboard. But the Gnome keyboard is always displayed although it is switched off in the settings.

Does Onboard work with both?

The package name is Caribou

You would think that you could just uninstall Caribou to solve the issue. But... Gnome doesn't like that. It likes to break the Gnome shell if you remove it.
And if you do manage to remove it - it is likely to re-appear with a system update.

Another option is to use the following Gnome Shell Extension.
First, install dependencies:

sudo apt install libproxy1-plugin-networkmanager gnome-shell-extension-system-monitor


Once installed, enable the extension using the Settings > Extensions reboot and test...

1 Like

Thank you very much for the support. With the extension it works now as usual.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.