"Open terminal here" command

I upgraded Thunar today and now the "Open terminal here" command is linked to Exo terminal which I don't have and gives me fallback error.
How do I get my Debian terminal back ?
Most probably this will involve editing the execution code of the option but I don't know what to write

Also the new version has somehow removed the text wrapping feature so now every row is of unequal height and a good portion of my right side of window remains blank.
All in all -- Don't upgrade thunar

Debian terminal or gnome terminal?
Can you please launch Thunar, then click Edit > Configure Custom Actionsand open the "Open Terminal Here" action (double click it).
The Command option is the one you want.
Replacing with the command:
/usr/bin/gnome-terminal %f
...will work.