Opening GUI of touchegg

Try this

1 Like

This one is regarding the old version of touchegg ( 6 years ago). The code was almost entirely rewritten this year and so I don't think this will work

Are you looking for this?
It is already included in Zorin (as FlatPak).

2 Likes

Yes I am looking for this but it isn't installed on my system

What did you search for ?? Because searching "touché" or "touchegg" shows nothing on my system

As, FrenchPress and Elegant_Emperor mentioned it can be found in the Software store.
Try searching for "touch", but I guess you don't want to install the Flatpak version.

So Elegant_Emperor mention the one directly from github, see his previous message. This is also the one which is mentioned in the print screen above.

I want to use the github one but theres no ./configure in it. How do I install it from github ?

Download:
https://github.com/JoseExposito/touchegg/releases/download/2.0.12/touchegg_2.0.12_amd64.deb

Double click to run the installer.

This is the touchegg one,which is installed by default. I want to download the Touché (the gui for it)
Here's the github link to it.

1 Like

You are right - I followed the right link... But got the wrong package. Apparently, the Touché .deb installer has been removed and the developer only offers flatpak, now.
...
Well, then.
Reading his commentary, he seems to have become a bit antagonistic for Debian, though I may be over-thinking it.
Looking at the source code, the workings are all in place to compile as a .deb.
Use cd command into the directory containing debian folder.
Not inside the debian folder.
Now run the command

dpkg-buildpackage -rfakeroot -us -uc -tc

This should generate a local .deb package. You can then install it with

sudo dpkg -i ../touche_*.deb

(Or go to the created .deb and double click to install it)

dpkg-checkbuilddeps: error: Unmet build dependencies: appstream-util debhelper-compat (= 12) gobject-introspection libgirepository1.0-dev meson (>= 0.49) nodejs (>= 8) npm (>= 3)
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

Seems like I'm missing dependencies..
Should I use apt-get or some other source ?

Just for your information:
I routinely avoid Flatpak and SNAP but I also have some exceptions.
Touché is one of them and it works perfectly on Zorin 16.

1 Like

Are you on Zorin OS 15 or 16?

@Frenchpress 's suggestion is a valid one, too.

1 Like

Zorin 16, why ?

Because Zorin 16 uses GNOME desktop whereas Zorin 15 uses either XFCE or GNOME. Different desktop may require different solutions.

1 Like

Yeah, my entire desktop environment is gnome, the only thing I've changed in that regard is the default file manager ( Nautilus to thunar)

Because this:

would need to be =9 on Zorin 15. I was just checking if that was the trouble (it's not, since you are on 16).

I still think it is much easier to install Flatpak version from Software, unless there is absolute necessity to avoid Flatpak.

3 Likes

I agree with @FrenchPress. I actually like Flatpak and Snap even though most others hate it....I know most snap apps are buggy and laggy but I usually use .deb or apt to download those particular packages. All others are flatpak. I don't use any snap packages right now (I used WPS Office and Bluej previously). As far as storage is concerned I have lots of them, so I don't really have any issue with it.

1 Like

A contradiction, here...

3 Likes

Yep, I clearly made a mistake there. Edited it now....I liked the snap version of WPS office which was very smooth and faster as compared to the .deb package. I also tried Bluej (the snap version) to get rid of a bug but the bug existed in the snap version as well. Look here:

2 Likes