OPENVPN problem

I was using proton vpn and it was working well I tried to upgrade my Zorin OS to 17.1 education but it failed it took more than 3 hours then I canceled it I killed it from the "System Monitor"
since that time proton not connecting stuck with connecting to
then I thought about OPENVPN to solve this.
I created account and tried to install

using these steps but with last step this

sudo apt update && apt -y install openvpn-as

I got this error

E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

also I creayted this point and always when I'm trying to connect it's loading then not connecting

That error message means that there's another process using the dpkg which is the package management tool used for updates and such. Did you have your Software Store, or some other process, checking for updates or similar?

Actually, scratch that. You forgot to use sudo on the second command:

sudo apt update && apt -y install openvpn-as
1 Like

Did You used sudo for the first Command too?

nope I had nothing like that


Please check your input, you're not using sudo on the second command.

Also, you said that you never completed the upgrade process, but the repository you added was for Jammy.
Did you mean to add Focal?

I'm using sudo with all these commands

Can u explain more ?
yes I couldn't complete the upgrade from 17 to 17.1
not my OS 17 stable and everything is ok as I can see

1 Like

Ah... I had thought you were referring to upgrade from Zorin OS 16.3 to Zorin OS 17.1

You are right, Jammy is the correct repository for Zorin OS 17 edition.

@Aravisian @zenzen the problem still active

VPNs can be a pain to work with sometimes. The clients like to take over certain configuration files, and when something goes wrong they can leave them in a bad state which makes things difficult troubleshoot, and recover from it.

1 Like

So, I've looked a bit more into this and I wonder which instructions did you follow to install the VPN? I would suggest following the instructions from Proton, or whatever other provider you intend to use, just to be on the safe side.

And I would also consider completely uninstalling everything so that you can start from scratch. It's possible that some configuration file was left behind and is now poking the network settings, without noone noticing.

I used to install using the instructions from proton website and it was working but IDK what happened

I'm asking because the first screenshot in your opening post looks different from the documentation that I linked above, and I also couldn't find anything regarding "access server" in there.

Try to uninstall everything from openvpn, protonvpn, etc., and try again from scratch. The tricky part is that it's sometimes difficult to find all traces to remove to do this successfully... that's what I mean when I say that working with VPNs can be an absolute pain. Normally, providers have good documentation on how to do this step by step though, so make sure to search for that.