Opera browser does not start full screen?

We all have a favourite browser mine is opera, my minor problem is it will not open full screen, I have to click the restore button every time it loads so it is full screen, not a big issue but a bit annoying.

I can see how that would be annoying. You might edit the .desktop file exec line to include --start-maximized %U

1 Like

Could do that if I knew how, Linux novice here and an old one as well, as in age loll

Same here. And I consider myself old... I sure am feeling very old right about now...

But this is quite easy.
First, to make life easier, let's go about it using the GUI method.
We can use a terminal CLI method if you prefer, just ask.

But GUI method starts with terminal:

sudo -i

to elevate the terminal to Root. Now, launch your file manager.
If using Zorin OS Core:

nautilus

If using Zorin OS Lite:

thunar

Now, navigate to Root
In nautilus, you must hit "Other locations" then "computer" to get there... In Thunar, you can just hit the Up Arrow on the Toolbar three times.
Navigate to /usr/share/applications
Right click the Opera .desktop file and select to open it in the Text Editor.
Scroll down to the exec line. It may look something like

Exec=/usr/bin/opera-browser

Or similar... put aspace after browser and add the above parameter including the double dashes so it looks like

Exec=/usr/bin/opera-browser --start-maximized %U

Save and exit.
You can exit the file manager etc and log out, then back in and test.

2 Likes

Thank you, not sure what I was doing but I did it! many many thanks. :innocent:

1 Like

All you needed to do was believe in yourself.

1 Like