OS refuses to use GPU

For some reason Zorin refuses to use my GPU, I tried multiple different drivers none of which worked. I tried completely purging my drivers with sudo apt-get remove --purge '^nvidia-.*' then I entered recovery mode and reinstalled drivers sudo ubuntu-drivers install nvidia:545 Then I did sudo prime-select nvidia which did nothing, the gpu isn't broken nor is it over heating it works fine in Windows.

One scenario it could be is that Windows has taken "control" of the GPU. To fix it shut down the computer completely as Windows doesn't really shut down but goes to hibernate state.

Another scenario could be that fast boot and secure boot is enable. Make sure they are disabled.

Both had been disabled to begin with, the gpu was working fine for two+ weeks for some reason it just doesn't want to work

Lets check the driver and status of your card:

sudo apt install inxi
inxi -Ga

The inxi shows us that your system is using llvmpipe instead of nvidia driver when rendering OpenGL.

sudo apt update && sudo apt upgrade
sudo apt install linux-headers-$(uname -r)
sudo apt install --reinstall nvidia-driver-545
sudo prime-select intel
sudo prime-select nvidia
sudo reboot
1 Like


Not much change it seems

Have you tried driver 550?

550 was where my problems first started unfortunately

Okay, I recall that now you mention it.

Can you check if libnvidia-gl-545 is installed?

apt search libnvidia-gl-545

You could also make a complete purge of nvidia packages and start again installing the packages again. My suspicion is that there are leftovers from 550 somewhere.


appears to be

Hm... I'm now bit out of ideas what's wrong other than purge the driver completely and start over.

sudo apt remove --purge *nvidia*
sudo reboot
sudo apt install nvidia-driver-545
sudo reboot
inxi -Ga

It also shows the Display protocol as Wayland.

Aye... I wonder if it has any impact?

@Ztest17 can you switch to X11 to test it?

Sunova... I completely forgot I was using Wayland. Occams razor every single damn time.

1 Like

I did everything the hardest way lmao, the first thing I did was completely purge my system of display drivers and reinstall them in recovery mode. And this whole time the solution was clicking a single button.

1 Like

Nvidia doesn't work with Wayland. :wink:

I'm aware I was using it for a quick project and it just completely slipped my mind that it was still on. Idk whether to be embarrassed or relieved.

1 Like