OS still cited even when uninstalled

I installed Zorin OS and after a while this screen appeared when I tried to log in again. And I just ignored it by formatting and installing another Linux, but when I check the bios boot list the term "ubuntu" is still in the list and when I try to log in it still shows this screen.

It even shows the disk with nothing on it, fully formatted several times. I've already tried using chatgpt to try a solution and none of them work:

  • efibootmgr
  • sudo rm -rf ubuntu (Inside the /mnt/efi folder)

I tested it just today if I install Zorin OS again it works, and yes it does, it uses the same term that was in the boot order.

I had edited GRUB and then forgot to run update-grub, so the changes were not applied. :expressionless:

So I tried it too. chatgpt recommended "sudo grub2-mkconfig -o /boot/grub2/grub.cfg" because I did it via Fedora. But I also did it using update-grub

Here's how to remove grub, be careful!

1 Like

Well, would that solve the problem? Well, I don't think so, since it's not on the sda, but it is.

Like, the word "ubuntu" still appears in the boot order even though there's no other file on the sda.

Like now, I don't have any linux installed now I just have Windows on another ssd, but it keeps saying that I have Ubuntu as bootable in the bios and it just returns me to this screen.

I can't say for sure, but if it does what is says, it should. I also ran across re-writing (blanking) your MBR, but that sounds a bit drastic. I can't recommend that.

In my case, I just leave them. Part lazy, and part diabolical, with me knowing the only route to a bootable machine. :grin:

What is in your /boot/grub/grub.cfg file? I'll bet an entry for Ubuntu...

This Entry in the BIOS is a ... how can I say that ... ''empty Entry''. So, there is no Linux anymore installed, yes. But there is still an Entry in the BIOS; this isn't unnormal. There is a Way to delete this Entry in Windows, but is is a bit complicated. So, if this doesn't annoys you too much, I would suggest to ignore it.

If You don't want ignore it, I could give You a Link to a Youtube Video what explains it and You could follow them carefully Step by Step. I used that in the Past a couple Times too and it works.

1 Like

I'll check and delete it if there is one. But I think it's almost impossible since even with the ssd FORMATTED without anything inside it, ubuntu still appears.

Is there any way I can do this using Linux via a USB stick? Because I think that if I go to Windows it's complicated, it's better to try to go from the easiest for now and then try to the most difficult

I just looked in /boot/grub/grub.cfg and found nothing about Ubuntu.
But I think that must be because I looked on the USB stick itself testing Zorin and not with it installed on the ssd, is that why?

I retried this command to see if I'm doing it wrong and it says I need cows.

/usr/sbin/grub/probe: error: failed to get canoncial path of '/cow'.

What you are seeing is the bootloader entry.
Bootloader entries are stored in the EFI partition, not stored in the Operating System (Windows OS or GnuLinux like Ubuntu).

If you wipe your GnuLinux distro installation, then the bootloader entry, if selected, will fall back to the grub prompt, as you can see on your screen.

On GnuLinux, you can remove, move or edit bootloader entries using efibootmgr. But since you have wiped your GnuLinux, you cannot use its terminal.
Nor will other GnuLinux commands work.

On Windows OS cmd prompt, you can achieve the same, as @Ponce-De-Leon pointed out, a bit complicatedly, using the bcdedit command, locating the Ubuntu Identifier, then using the identifier in bcdedit to remove the entry. I do not use Windows, so amn not well-versed in the use of the Windows Tool. You can find look an internet guide on using bcdedit that will likely be more informative.

To be honest I don't know. If You want to take a Look on it here is the Video. The Uninstallation Part with the delete of the Entry in the BIOS begins at 11:45:

Yes, but the Entry in the BIOS will still exists then - unfortunately. With this bcdedit Step You can simply delete the Grub Stuff, so Windows starts normal. But to delete the Entry in the BIOS is one more Step needed. It is shown in the Video.

1 Like

Ok ok, I'll try the Windows solution and report back soon.

1 Like

Well, I've just done the solution mentioned above by Ponce-De-Leon. And I have a few things to mention:

  1. The process is not difficult at all, it's just a matter of paying attention to what each command is doing and how to do it.

  2. My ssd that had Linux on it was already empty with nothing on it, so I found it strange that I had to go and list its partitions. But what I did to solve it was to go to the disk where Windows is. I listed the partitions and saw that there was a system partition and there was the Ubuntu folder.
    (This may have happened because I didn't pay enough attention when installing it and didn't make sure that the boot partition was Linux.)

But it all worked out in the end! Thank you very much for your attention Ponce-De-Leon, Aravisian, rootboy, Hackgets!

2 Likes

Good that it helps You.

That is because of the EFI Partition. To install Zorin (or other Distros) You need 2 Things: A FAT32 formated EFI Partition and for the Rest an ext4 formated Partition.

On a Dual Boot System with an existing Windows You already have a FAT32 formated EFI Partition from Windows. And the Installer should automatically detects this and use it. And that is a good Thing because it makes the Dual Boot easier.

3 Likes