OS won't recognize recent Nvidia GPU (but still runs games)

So I recently got an RTX 4060 and I plugged it in and all, but I'm in this weird state of limbo where my system sort of recognizes it but also doesn't.

Let me explain:

  • Some games work, but others just freeze randomly or run significantly slower than they should. All games ran faster on my previous GTX generation GPU.

  • My CPU does not have integrated graphics, so obviously it is using the GPU, but when I run neofetch, I get this instead of "Nvidia RTX 4060":

GPU: NVIDIA 02:00.0 NVIDIA Corporation Device 2882

  • I also noticed there is no option to switch to Wayland in my login screen and I tried to manually switch over via terminal and it reverted back to x11.

System Information:

-ZorinOS 16.3 Pro
-Nvidia-driver-535 proprietary driver
-Games are on both steam and lutris

My theory is that the OS doesn't recognize the card but the driver is able to provide some performance. I would like to upgrade to Zorin 17 obviously, but at the moment there is no in-distribution upgrade option for me.

If anyone is running a 40 series card on Zorin, please let me know what I can do to turn it into a good gaming experience.

This is not unusual on Nvidia.

Nvidia also gets poor support on Wayland. My RTX 3060 surprised me by working on Zorin OS 17 on Wayland when I was testing Zorin OS 17 Beta.

Is there a chance that upgrading to Zorin 17 once it's ready will fix it?

I had a lot of troubles with the 535 driver. I notice other users have. I use the 525 driver, instead and it gives zero issues. Due to this, I recommended to others troubled by 535 to switch to 525 and it helped them. So, it is worth trying this as a quick possible solution.

Yes, there is; Zorin OS 17 will come with 6.3 kernel. However, you can install the 6.3 kernel on Zorin OS 16.3 as well and see if it helps.
On Zorin OS 16, use the TuxInvader supplied mainline kernel (I am currently on 16.3 with the 6.3 kernel):

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

The 6.6 kernel is also available on the TuxInvader repo:

sudo apt update && sudo apt install linux-generic-6.06

Fixed the neofetch issue with the help of chatGPT, here is what I ran:

sudo update-pciids

Also, if I change kernels, will it break the upgrade path to zorin 17? Or will the upgrade override my "custom" settings?

1 Like

Having a different kernel should not break the Zorin Upgrader, now. The updgrader checks for the minimum package requirements and does not differentiate on higher than requried.

Thanks for sharing this - you taught me something new.

I am on 6.6 and testing my most intensive games. I'll let you know how it goes.

1 Like

It works significantly better! Thank you so much!

1 Like

By the way I invite you to try Nvidia-535 on kernel 6.6 on X11.

The performance difference is unreal.

1 Like

I will test it.
I have had some small issues with some games. No lag or anything, just Very High CPU temps...

1 Like

I am now on the 6.6.5 kernel, and 535 driver... and at least some of the glitchiness is alleviated, but not all.
FPS and performance are improved as is Much Lower CPU Temps. Which I have been trying to solve the CPU temps issue for this past month - including replacing the thermal paste on the cooler.

Thanks for the suggestion. It has helped me out.

1 Like

Is that a typo and should read as "now" ?

Yes... I am up way too late. Thanks for spotting and letting me know - I have corrected it in the original post.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.