Password authentication failed. Upgrade zorin 17.1

When trying to upgrade Zorin Lite 16.3 to Zorin 17.1 from the Zorin Updater, I get the error: "Password authentication failed. Please try again." and at no time does it allow me to log in with a password or ask for authentication. I have tried to change the user permissions from the graphical interface of my user and it tells me in account type: custom and does not allow me to change it or access the advanced options. I clarify that I only have one user which is the one I used to install Zorin, the same one is included in the adm and sudo groups. From the terminal I can access as root user and check that my user does have all the permissions, what would be the solution?

Do you have enabled fingerprint login?
If not so try to login as root and then change the password for your user with

passwd username

I did not enable fingerprint login. I logged in as root from the terminal and it's still the same, I also changed the password and it didn't work. Or should I do it from grub?

You might have a corrupt Xauthority file. I covered this in the unofficial manual for both Zorin 15 and 17 under the login loop issue.