Password Nonfunctional After Enabling Fingerprint

Hey all,

I tried to follow this guide to enable fingerprint login and I modified the PAM configuration to look like this. However, upon rebooting, I have auto-login enabled and a prompt comes up for "Unlock Login Keyring" for my password. It works in that menu, but my user account password no longer works in Terminal nor Settings. The fingerprint option does not display in Settings > Users, and If I return to pam-auth-update , it shows it as enabled.

Any thoughts or ideas on how I can fix this are greatly appreciated!

Did you have autologin enabled when you tried setting up Fingerprint authentication?
Autologin would interfere with that process.

Yeah, Autologin is still enabled and that's the only way I can access my account. I have enabled it in PAM but not set it up in Settings, if that's what you mean.

I suggest undoing that, then disable autologin completely.
Once done, follow the steps to enable fingerprint login.

Also, please relay the Fingerprint device, to check the drivers and ensure that it is supported.

Well, therein lies part of my problem. I cannot enter my password to run sudo in Terminal, and if I run pam-auth-update without, it launches but makes no changes.

And to answer your question, my PC has the Synaptics VFS7552 .

Are you the person who installed Zorin OS on the computer or is this a user account under another persons ownership?

I installed Zorin OS and am the only user on this PC, unfortunately.

Also apologies for overlooking your reply, but I'm not certain I understand what you're referencing in the linked post. My primary concern is just getting full access to my account back, and this seems as a bug with the OS to just outright strike my password.

I see options online to nuke login passwords with a USB Linux drive, but I can't seem to get around LUKS that I enabled at install. It seems my curiosity is my enemy as of late.

You enabled Disk Encryption, as well?

You could try

sudo passwd

And changing your password... Then rebooting and seeing if the password works in terminal.
This is an odd cascade of an issue. I agree, I have never heard of the system nuking a persons password, either.

Interesting result; running passwd accepts a change, but does not change the password that I use to run overrides & login from the lock screen.

Well... if using Disk Encryption and Fingerprint Login... It defeats what autologin would offer.
How do you feel about (painfully) reinstalling Zorin OS?
Are you able to back up your personal files and try a fresh start?

Right, I understand. I more was curious on exploring the functionality, to my own detriment. A reset may be my only option, given my circumstances. I just avoid it like the plague, since some apps I have are a pain to reconfigure (i.e. YubiKey, DisplayLink, RStudio). Thank you for your time, regardless.

fwupdmgr upgrade
fwupdmgr upgrade

returns "No updatable devices". However...


Returns "Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available" , which I fear may be the culprit.

1 Like

Your fingerprint device is?

Synaptics VFS7552


It offers Zero Linux support...

1 Like

Double Wow, It Does not work on any Linux :joy:


1 Like