Paste not working 17.1

Using Zorin 17.1 for some reason I can copy text but cannot paste including trying hotkeys (Ctrl + v & ctrl + shift + V). Its the same for me even after having reinstalled the OS.

Anyone got any ideas?

Are you using a clipboard manager?

If not, can you navigate to Settings or Configuration > Keyboard > Shortcuts > Custom Shortcuts (I don't remember with Zorin 17 on Gnome if its direct from Settings or configuration first...)
See if ctl+c, ctl+v, ctl+z are set. If so, remove them.

Reboot and test...

Does this happen with all programs or only a few specific ones?

as far as im aware its everywhere

they are not set, but shouldn't they be? Shouldn't I add them here?

Even within the same program? For example if you copy some text from this thread and paste in the address bar, does that work? What if you try with the mouse? And on the right-click context menu, does the option appear grayed out or as an available option?

sc1

Here for example the Paste option is available but Copy is not (as I didn't highlight any text).

That screen is for custom actions, so the shortcuts should already be set within the Zorin OS configuration.
But you can try adding them to see if that works.
If it does not - remove them again.

In terminal can you try:

sudo systemctl restart clipboard

Then test if the shortcut is working.

It may be that some custom configuration is interfering. You can try backing up your user configurations in terminal

mv ~/.config ~/.config-bk

Then rebooting and testing if that restores functionality.
If it does not, you can revert with

mv ~/.config-bk ~/.config

So this worked. I was able to copy with ctl + C and pase with Ctl + V (and also with right click too).

However, I was just on a forum and it absolutely didn't work, I just went back to paste the comment I tried here and it worked....So it is intermittent.

Interestingly....when I was typing this message one word came up with a spelling suggestion as I'd made a typo and it had the red line underneath. I left clicked it to see the suggestion and then the phrase I had previously copy pasted just pasted into the message box. I left clicked again and again and the message pasted again and again....very very weird

Hey, guys, anyone got any ideas about this? Im still having this issue. Also, is it not possible to copy paste into the Terminal? As I can't do that either and wonder if it is standard or if this relates to this issue I am having.

I'm all out of ideas to be honest... does this happen with text only or some specific files? For example when you take a screenshot you can copy to the clipboard and paste it as an image in things like Gimp. Does that work for you?

You should be able to paste into the terminal just fine using right-click -> Paste, or with Ctrl+Shift+v.

I can copy paste images just fine and even with the hotkeys as demonstrated with the pasted image below

. copy pasting text is the issue. sometimes it works, sometimes it only works when I right click to copy paste and other times not at all.

Nothing works to copy paste into the terminal though.

1 Like

Given that it is missing on right click as well as the keyboard shortcuts, this narrows it to a system fault, not a keyboard (hardware) communication fault.
Have you tried freshly reinstalling Zorin OS?

It's quite bizarre that images are copied correctly while plain text isn't...

I'm not reinstalling Zorin again :joy:

Don't you remember the nightmare we had with that? It seemed everything that could go wrong did! haha

its not that it does not work all the time both with hot keys and right click. It is very inconsistent. copy pasting to and from certain places produces a variety of different results.

However, nothing works copy pasting to or from the terminal...

Same. This is a strange issue.

I did some looking into the code behind this to try to get a handle on it. This led to some surprises... Copy and paste relies on the display protocol. Interestingly, this means that copy over paste does not work in Wayland. I did not know that.
This is a new issue I have never encountered on Zorin OS before - and Zorin OS is newly using Wayland as default.

I do not doubt that switching from one display protocol to the other will not solve the issue. It might and is worth trying, but I suspect the would lie in XWayland - where the functionality is patched in at present until Wayland is able to fully handle copy/paste functions.

1 Like

You can quickly switch between Wayland and Xorg at the login screen, on the lower right corner there's a button to select one or the other.

Just keep in mind that you have to login to your account first, and then logout, as it won't be showing the first time you boot your computer.

I have switched from Wayland to Xorg and back again already. the issue persists on both...