Pause function shortcut not working since 16.2

I have a wireless keyboard connected to a laptop running Zorin OS 16.2.
Previously, I was able to use the keyboard-specific special functions (as in, Fn + F1 - F12), but since the update the Pause function does not work anymore.

In my case, the Fn + F11 combo on a Logitech K800 keyboard would pause any media playing. However, it is now non-functional. Media playing in Chrome (e.g. YouTube) does not respond to the command, VLC playing a video will "flash" as if it was briefly paused then immediately resumed, the podcast app I use does not respond either.

All of the other commands seem to work.
My laptop keyboard also has some Fn functions, all of which seem to work as well, but unfortunately no equivalent to a play/pause function so I don't know if this issue is specific to external keyboards.

Overall, it looks the the play/pause signal sent by the keyboard isn't recognized by Zorin as such anymore.

If using Zorin OS Core (Gnome Desktop), the Gnome d.e. may have taken control of those functions.
Can you try:

gsettings set org.gnome.settings-daemon.plugins.media-keys previous ''
gsettings set org.gnome.settings-daemon.plugins.media-keys next ''
gsettings set org.gnome.settings-daemon.plugins.media-keys volume-mute ''

All three return :

expected value:
  (empty input)
  ^

Also, wouldn't those commands only affect the previous, next and mute buttons ? So far, only the play/pause one is causing troubles.

Yes, you are right. If any of the keys are bound, then all the keys can be affected. If you unbind the keys, then it should unbind them all.
I really need to slow down and hurry less when replying to posts...
As to:

I can only take from that that in the later versions of Gnome / Ubuntu, something changed to disable that. I looked into it and found this thread (among others):

Where it seems quietly removed. Well, that is Gnome... quiet removals followed by justifications and lack of action does not surprise me any.
The Gnome Control Center side seems to be the culprit, by this thread. And the reasoning appears to be that they do not want customers rebinding keys.
Which... would explain the information above about Gnome seizing control of keybindings which led me to offer you gsettings for those keybindings, instead.
Which now are also not working.

Can you next try:

killall gsd-media-keys

Then tap alt+F2 and paste in:

/usr/lib/gnome-settings-daemon/gsd-media-keys

Tap enter key and test the play / pause key.

I am sorry that I am not much help on this. I do not use Gnome and this thread shows why: I find Gnome to be far too much like Microsoft. Quietly taking control.
I use Zorin OS Lite which lacks Gnome Control Center. So I don't really run into these issues on my machine.

/usr/lib/gnome-settings-daemon/gsd-media-keys results in "Command not found".
I looked through /usr/lib and I found a folder name gnome-settings-daemon-3.0 but it doesn't contain anything named gsd-media-keys, nor does the whole /usr/lib for that matter.

killall gsd-media-keys did effectively stop media keys from working, even the one that were still functional.
Using gnome-settings-daemon and 'gsd-media-keys' in both the regular and Gnome terminal resulted in "Command not found".

I am sorry... try

systemctl --user restart gsd-media-keys.target

to get them enabled, again.

Datburned changes...