PC freezes during guided installation

Hi everyone,

I’m new to the Linux world. I was searching a light distro for my HP Compaq 6720 (Intel Cerelon single core and 1GB of RAM) and Zorin was a great solution! I downloaded the ISO (Firefox, one of the latest version) and flashed it on the USB (8GB, with Balena Etcher).

When I was using Zorin on the USB, everything was fine, until I went to settings to find addition drivers: it froze. I had to force shut down the PC and then boot it up again. After that, I started the guided installation, but (again) it froze when I clicked next on the “Updates and other software” page. Tried again, but same problem.

Any solution?

Can it be that I’m using a 4G router? About that, I noticed something weird. Normally, even when I use 30mbps in download and 20 in upload, the Wi-Fi is still usable, but during the download of Zorin’s ISO everything was weird: the PC was downloading without problems, but other devices didn’t work: I tried running a Speedtest but 90% of the time it didn’t even start! Maybe the ISO got corrupted… It would be great to download it via torrent!

I’ll appreciate any help!

(sorry for my bad English)

1 Like

Hi @matt, welcome to the forum!

It appears that there may have been an issue with your installation medium. I would recommend you to check if the installation medium may have defects by following the steps on this guide: https://zorinos.com/help/install-zorin-os/#boot-from-the-install-drive

If defects are found, I would recommend you to try burning the downloaded Zorin OS .iso file to a different USB drive, as the first drive you used may have experienced wear & tear from prior use or had other physical defects.

If the issue still persists, it might have been caused by a corrupted download file. I would recommend you to try downloading the Zorin OS .iso file again using the latest version of Firefox or Google Chrome without any third-party download managers (in order to avoid file corruption). You can verify whether the file has been downloaded correctly without corruption by verifying that its sha256 checksum matches the one listed after pressing the “View sha256 checksums” button on this page: https://zorinos.com/help/install-zorin-os/#download-zorin-os

To verify the checksum, we would recommend you to use an app called QuickHash, which can be downloaded from here: https://quickhash-gui.org/downloads/

After opening QuickHash, please navigate to the “Files” tab and select the “ sha256 ” Hashing Algorithm before clicking the “Select File” button to choose the Zorin OS .iso file and waiting for the checksum to be generated.

1 Like

Hi,
Thank you for the help!

I checked first the USB and it said that there were no defects, then I checked the Sha256 and it matched.

What should I do?

1 Like

Does the computer you are installing to already have an installed OS on it?
Using either gparted in the Zorin Disk or using a partition Manager on the already installed OS on the computer, can you check whether there are currently Four Primary Partitions in use?
On any OS and any computer, you can only have a Maximum of Four Primary Partitions.

  • Note: this can get confusing because developers created a workaround that allows them to create multiple Sub-partitions on One Primary partition. So if possible, a screenshot of the available or used partitions can help a great deal.
1 Like

Please make sure that you are using Zorin OS 15.2 Lite or one of the Lite derivatives (Ultimate Lite or Education Lite), as these are the only editions of Zorin OS that run on computers with less than 2 GB of RAM.

After booting the Zorin OS Installation USB drive to the desktop, please follow these steps without opening any other apps:

  1. Click on the network indicator in the left side of the bottom panel to connect to your network
  2. Open the Zorin menu > System > Terminal
  3. Enter the following command: sudo apt update
  4. After the command finished running, close the Terminal window
  5. Double-click the “Install Zorin OS 15.2” icon on the desktop to start the installation process normally

Please note that running Zorin OS from a USB drive will run slower and uses more system resources & RAM than after it’s installed to the computer.

1 Like

Hi,
I tried running the sudo apt update and when it finished I closed the terminal but still, during the guided installation it freezes. I’ll send a pic of gparted, I hope this can help.

1 Like

It does help; that answered the partitions question perfectly.
Given that it froze on “additional drivers” and during installation, I wonder if the graphics drivers are responsible.
Something you may try:
Boot up the machine from the USB and when you reach the Grub Screen that says

  • Try Zorin
  • Install Zorin
    and so on… Note: this is the grub screen you see prior to trying out the OS in the LiveCD demo…
    Do not select any of those options but instead hit the “e” key.

This will open a Terminal Text Editor for a temporary grub. Using your arrow keys, navigate through to where it says “quiet splash.”
Replace just the words “quiet splash” with “quiet splash nomodeset”
Then hit ctrl+x keys to continue onward. Try the installation again.
If it freezes, you can try repeating the above steps but instead of adding “nomodeset”, instead add “quiet splash modprobe.blacklist=nouveau”
And try to install again.

Assuming either of the above gets things moving again, be sure to select the option during installation to install third party drivers.
Once installed, boot up and then immediately repeat Azorins advice above:
Open a terminal and enter in

sudo apt update

then

sudo apt upgrade

1 Like

Thank you for the detailed answer, but I pressed it and what happen is the countdown to the automatic boot restarts

1 Like

Can you try using the arrow key to Highlight “Try Zorin” and then hit the “e” key?

1 Like

I highlighted “Try or Install Zorin OS”, pressed the “E” key but the screen stays still
Sorry for the bad quality pic

1 Like

Well, then.
Um…
Have you tried dropping down once to Try or Install Zorin OS (safe graphics)?
That does what we are trying to do… and I may be outdated here. :smiley:

1 Like

Based on your screenshot, it looks like you’re seeing the legacy USB boot menu (which appears if your computer doesn’t support UEFI).

Instead of pressing the “e” key here, please press the Tab key to edit the boot parameters as in Aravisian’s post.

2 Likes

This… is good to know. Learned somethin’ new.

Aravisian: Solving problems one step to maybe fifty steps at a time.

2 Likes

No problem :wink:
So, I tried with the tab key, as @AZorin suggested. I modified the text but when I pressed Enter, some text appeared (something like “no caching”), but it always happens but this time it was way more bigger and pixelated and after that a glitchy screen appeared. This happened when I selected the “Safe graphic” option and when I modified the text. It looks like the graphics is not causing the problem, I think, but I don’t know anything about Linux, and you are way more specialized!

I don’t know if it can help, but on the PC I have Lubuntu, recently I typed something wrong in the terminal and after that all system applications couldn’t work with internet, for example I can’t use:

use sudo apt-get update/upgrade
check application updates

Maybe this is causing this issue? Should I try installing another distro and then Zorin?

1 Like

It sounds like graphics issues to me. I wonder if, as Azorin pointed out, the mode of Legacy being used is involved. Can you go into the MB BIOS and just check that it is set to legacy and what it offers?
I do not think that the Lubuntu setting can affect this installation in any way. This LiveCD and installation is running independently of that.

This is true for installing another distro and then trying the Zorin installation again. And, you may run into the same trouble installing the other distro.

1 Like

Hi guys, I have a small update!
Guess what? I flashed on the same USB Xubuntu 18.04.5 and I could bypass the updates and drivers step! Now I’m busy, but when I’ll be free I’ll install Xubuntu and then Zorin! And let’s hope everything will be ok

So, I didn’t check the BIOS, but this PC only supports Legacy boot (it’s from 2007)

1 Like

Hi guys,
I successfully installed Xubuntu. I downloaded again the Zorin ISO and flashed it on the same USB.
It’s stuck (after 1 hour) at the “Updates and other software” page, the only that’s working is the mouse cursor but it’s very laggy

What should I do?

1 Like

Can you check through the suggestions in this AskUbuntu thread and see if any help?

1 Like

Hi,
Thanks for sending me this link! Unfortunately, the problem persisted.
For no reason, I downloaded Zorin 12.4 and it worked!

Thanks for the help! So happy to use Zorin! :smile:

1 Like

So Zorin 15 was still “too new” for the hardware?
Good thing Zorin 12.4 still is supported with updates for a while yet. :wink:

1 Like