Pendrive issue

hey i bought a usb 3.1 pendrive it has support upto 130 mbps but it does'nt giving me half of it at starting of copying a almost 4gb file it gives approx 70 mbps but after few seconds it drop on 10 to 20 mbps

AND PASTING speed is even more less from starting it give 30 to 40 mbps and then drop over 10 to 15 mbps

Does your USB-ports support 3.1?

i don't have an idea but i tried to check all ports have same colour

and one more thing i discovered only in 1 port i am getting upto 50 to 60mbps speed in other i am getting just 10 to 20 mbps max to max max 30mbps and in that 1 port i am getting peak at 70mbps

Post the output of:

lsusb

You have one usb that support 3.1 the rest are v.2.0

Let's try this
Insert your USB in 3.1 port and open the terminal, run this command to figure the name of your USB stick.

sudo fdisk -l

Then Disable the write cache for the device by:

sudo hdparm -W 0 /dev/sdX

where sdX is the name of your USB stick.
See if it improve the speed. When reboot cache will be enabled again.

hey after entering that command i was shown this what should be next move

Try copy/move stuff now to the pendrive and see if it improved.

ya i tried it out but only improvement of 10 to 15 mbps now also it is not the half of its peak speed

TRy copy via the terminal and see if it improve the speed. It might be a Gnome/XFCE thing.

how to do that?
can you share steps

cp -r [file/folder] /dev/sdb1

bro showing this error

My fault I use [ ] to show you need to put the adresse of the file.
So it should look like eg.

cp -r /home/username/file /dev/sdb1

bro now also getting stucked

When using cp -r you set the target file first and then after that you set the distination.
example:
cp -r /home/storm/Documents/my.file /dev/sdb1

or the other way around:

cp -r /dev/sdb1/my.file /home/storm/Documents

hope it helps.

1 Like

Your computer has ports that are older technology than the thumbdrive that you purchased. While new usb standards require backward compatibility, the speeds are limited to the version of usb that accesses the drive. What that means is that two ports of your computer will be limited to usb2.0 speeds and one will be limited to usb3.0 speeds. Your computer doesn't support usb3.1. The drive will work, but not at the 3.1 speeds. There is no getting around the limitations of the hardware except by purchasing a computer with those new standards.

3 Likes